NAT fixed

I have a Comcast SMC gateway in bridge mode with a Netgear R6300. This worked for me and may work for others as well but I'm not sure.

When I first got the Xbox One, I did everything according to Xbox support. Forwarded all the required ports, turned Upnp on, set the router nat setting to open. None of it worked. After waiting on hold for close to 50 minutes then giving up and trying chat support only to get someone who couldn't really help because they only knew the settings needed and nothing technical in nature, I decided to do a little poking around myself. 

What I discovered was that while my router had all of the right settings, I had completely forgotten about the SMC gateway. I had it in bridge mode and didn't realize that it could and was still blocking ports before they even got to my netgear router much less the xbox.  

So, I went into the SMC gateway and gave my Netgear router a static ip address and put that address in the DMZ zone (forwarding all ports to the router). For good measure I turned the SMC's firewall off completely, letting the Netgear's firewall take over.

With the correct settings already in my Netgear router, my Nat type immediately switched to open and has been ever since. I didn't even have to restart anything, though you may.

Hope this helps! 

 

Discussion Info


Last updated July 4, 2018 Views 6 Applies to:

I never had a problem with my Nat type in any game I guess am just lucky. thanks for the post to fix this for others...   :D

Nice. My router from Verizon Fios has me on moderate for all my WiFi connections and wired on my only Ethernet connection the Xbox One. So I believe it's the one doing the moderate because after one hard reset I was open on the one but a few hours later I was back to moderate. Very annoying and frustrating.

When you call your cable/internet provider and finally get to the highest tier of tech support they still don't know what the hell is going on and always say yeah i am a gamer also but all I can do is offer this. You see all this internet companies promote and advertise gaming and speed as a key selling point but don't know squat or better yet their tech support has little to basic info and knowledge on TODAY'S GAMING dilemmas. Which in turn turns into poor to little help resolving Nat and connection issues due to their routers which are all in one routers.

Yea DMZ opens all ports, that is an open NAT.

For those who don't know the proper steps:

Follow the steps below:

1. On the Xbox go to Settings>Network>Advanced. Look on the right hand side and write down your IP Address, Subnet, and Gateway.

2. Click "IP Settings" And enter all that same information in. For primary DNS use "8.8.8.8" and secondary use "8.8.4.4" (Google's DNS servers). After you are taken back to the "Advanced Settings" screen press "B" to save, if it says "Its all good" Then you're good to continue to the next steps, if it gives you an error, fix it or call customer care

3. Go to your router, and find "DMZ" click "Enable" And then enter in the "IP Address" You used for the Xbox One. Click save or apply then reboot the console.

After this test it out with multiple games, and everything should work fine. Also go to Settings>Network and your "NAT Type" Should say "Open"

NOTE: Make sure if you have any manual port forwarding set up on the Xbox's IP address erase them first, they can cause DMZ to not work properly. DMZ will open ALL ports and you will only need to do this once, if you rely on Manual Port Forwarding then you will have to re-edit your router configuration every time you buy a new game, DMZ will work for all games as well as normal Xbox online features.

If after doing the above steps and you continue to have issues, try the below steps:

1. Go to your router, find "UPNP", turn it off, save/apply, turn UPNP back on, save/apply, then reboot the console and test again.

2. Go to Settings>Network>Test Multiplayer Connection. If any errors pop up fix them, or contact Xbox Networking for support. If it says "Its all good" press RB+LB+RT+LT, then check your results with what's below:

Download Speed: 5 MB/S (Or higher)

Upload Speed: 4 MB/S (Or higher)

Upload/Download Packet loss should be below 7%

Latency should be below 120MS

Detailed NAT Information: You're stuck behind a Cone NAT

If you're results don't match up with the above then that could be your issue (I'm not giving a minimum, I'm giving the results I find acceptable for gaming) Fix those by switching to an Ethernet connection if you're using wireless.

If your Detailed NAT Information says "Stuck behind a Cone NAT" then your firewall is NOT causing an issue, if it says something else, then that's an issue. If it mentions the word "Symmetric" then that means your firewall on your Modem (Or a firewall somewhere outside of your network) and you need to disable that (As long as your router firewall is on you are safe to disable the modem firewall)

TheDyzaster.

You are my freaking hero. I wish I would have found this thread hours ago. You rock. No joke.

I think you missed the point I was making. DMZ will not fix the issue if you have an ISPs wireless router/modem in bridge mode in order to use your own personal router because no matter how many ports you forward on your personal router, they are still being blocked by your ISPS router.

For those few with that situation (apparently a lot of Comcast customers) you must first go into the ISPs router/modem and set your personal router into the DMZ so that you can then forward ports. Until this is done, your personal router can't do it because it's being blocked just the same as the Xbox.