My Xbox 360 won't turn on :(

My XBox 360 simply won't turn on. The green indicator light will turn on, but nothing else will. The controllers will not connect, the wireless adapter will not light up, and neither will the external USB Flash Drive. The light on the power brick even turns green, but it won't actually turn on.

This has been a normal issue with my Xbox. I will generally have to turn it on and off a few times before it will actually turn on, but this time I have spent over an hour turning it on and off, unplugging and replugging power bricks and HDMI cables, and it still didn't turn on.

There was one other point where a similar incident occurred and the Xbox simply would not turn. I was using a surge protector before and ever since I have stopped because someone had suggested that that may have been the problem. After plugging my XBox directly into the wall outlet, the problem persisted, but on a much smaller scale. 

Now the problem has returned. I have tried several different wall outlets, two TVs, and both RCA and HDMI connections and I still can't get the Xbox to actually turn on.

Please help

 

Question Info


Last updated July 4, 2018 Views 29 Applies to:

Anyone?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Sounds like a repair. Ring Support.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Is this an XBox 360 Slim? I regularly have this very same problem - the green dot in the centre lights up, but nothing else. It's as though it can't initialise itself as the ring doesn't even light up as it normally would when working. If I'm lucky it will work after a few tries at turning it off and on, but other times I could spend hours turning it off and on and get nowhere.

Annoyingly, I could then try turning it on the following day and it works straight off. It's very temperamental and because of this I can see an RMA being declined because it will typically work when they receive the box :(

Have you tried calling support? If so, what did they say?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.