My Xbox 360 Console Refuses To Power On

Alright, so I update my Xbox 360 last night around 3AM EST and it finished the update and it shut my Xbox off. I was sure it was just to refresh and reboot the system to apply the update. I waited for close to 20 minutes before hitting the power button thinking something went wrong. Nothing happened of course. My Xbox(Slim) still made the chime noise when I pressed the power button and the eject button, but nothing happened whatsoever. I figured maybe it hadn't finished or something. And I waited until this morning, and still I am at a dead end. I've tried unplugging all the plugs including my Kinect, my headset charger, the HDMI cable, and even the power cord a few times; it doesn't help, I still get the same sound and no results. I'm confused because my Xbox worked just fine before the live update. I'm rather certain it isn't a power issue or else I wouldn't hear anything reguarding noises. I'm afraid it may lie inside the console but I don't have the money for repairs and my warranty is expired. Is there anything else I might have overlooked or not tried?

 

Question Info


Last updated July 4, 2018 Views 0 Applies to:

Hey Batllekore,

This sounds like it could be frustrating to deal with!


Fortunately Miss Portia has taken the time out to make a thread based on this exact matter!

Please do come back and let us know if these solutions have helped you. Thanks 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.