My XBL account is broken...

A couple of days back i was going to play Battlefield 3 and when i started up the game it brought up all the welcome messages and settings as if i just got the game. When i went ingame all my stuff was all messed up and to go ingame and go set up all your primary weapons and vehicle settings takes 15min. I tried restarting my console and it brought up all the welcome messages and settings AGAIN, and all my stuff was once again all the way it was as if i just bought the game.

So i gave up after 2 more tries then finally give up and then try to play Skyrim, this time it gets worse. I started the game and i tried selecting "continue" and a error message popped up saying the disk is unreadable, i then restart it and try picking "load" and the same thing happened. Here's proof i know it's my profile, i signed into my brother's profile and ran Skyrim and everything loaded fine with no error messages, i put in Battlefield 3 and everything loaded fine and all of the settings on this account was fine. 

I tried deleting all my profile's game saves and the profile itself, redownloaded my profile and tried again, still didn't work with Battlefield 3. When i went in Skyrim i had to pick a new game and it worked, then i finally got to a save point, saved, and dashboarded. Can you guess what happened when i tried to load my existing save file? Same thing, an error message popped up saying the disk is unreadable. I did clean the disk the first couple of times when i got the error message but i know it's not the disk because there's not a single scratch or smear on that disk.

 

Question Info


Last updated July 5, 2018 Views 0 Applies to:

Look up your Skyrim save and see if there's an exclamation mark next to it. Also check to see if you still have problems when using a different profile.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.