My new white battery wont charge.

Hello everyone,

I have a problem with my brand new white Play and Charge kit.

First, i had a problem which i solved by myself. I put the battery in my white wireless controller, and it charged for about 5 seconds, then it stopped.

Finally, it started to charge, when put in my PC.

 

And there is the problem : My pc had to restart. I restarted it, so the battery stopped charging for a moment.Now, it doesn't want to charge, whatever i do, it charges for about 5 seconds, then the light on the P&C cable turns green. 

What should i do to charge my battery?

I tried every method i found in the Internet.

TL;DR: What should i do with my battery to charge it, if the first charging was interrupted?

 

Question Info


Last updated July 4, 2018 Views 7 Applies to:

UPDATE: Nevermind, i left it connected to the pc for 30 mins, and then unplugged the P&C cable out, and then back in Now, it's charging. Hope this helps someone!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.