MTU error!

i have tried every solution, it works when i plug it directly into the router using a ethernet cable, but on wireless i get the same old dump MTU error and i cant play any online games. Please help, i have a linksys WRT160N router with the latest firmware.

things i have tried: changed MTU amounts to auto, 1500, 1364, 1400, and 1500 - no luck same error

open ports - nothing happens

i narrowed it down to my routers configuration/hardware or my Xbox 360 wireless "N" adaptor.

 

Question Info


Last updated July 4, 2018 Views 89 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I have a couple questions/suggestions as the MTU in this case is not related to the actual MTU setting but fragmentation due to wireless interference.

First, do you have any other wireless devices you use with the Xbox 360? Things like the Turtle Beach X31 headset will cause MTU thanks to the transmitter being too close to the console. You can solve this by moving the transmitter away.

Also, are you on Wireless N for your network? If so, try switching to Wireless G. G runs in 2.4Ghz and is a lot more stable then N which runs in 5Ghz.

The WRT160N should not inherently cause MTU nor should there be an issue with the signal coming from it, so it's most likely due to a bad setting. Since it's a Linksys it does have the option for WPS or WiFi Protected Setup. Make sure that WPS is DISABLED as it will cause problems.

To do this, log into the router and click on Wireless.

It should bring you to the default page which will offer Manual or WiFi Protected Setup and you want to make sure you have it all manually configured.

Go with Mixed mode, Channel 1 OR 11, SSID set to broadcast, and lastly keep the SSID the same (Network name).

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have no idea why there is a bunch of @@@ symbols in my post...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Post fixed, FYI.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yes I'm on a wireless n network. Is there any way to lower it to 'G'? And no turtle beach just have a few computers on the network and the xbox is like 15 feet away from the router ( wall in between but this shouldnt really make a differencw. I did notice that my download usually only goes to about 3mps with download at 2.... I appreciate any help .

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I just had the same problem with my Xbox 360 after updating last night.  I couldn't connect to Netflix, ESPN, or even Xbox live.  I am on a Belkin N router with the current firmware for the router as well.  I had my 360 setup on a manual IP address due to having the NAT settings problem a while back.  Belkin has what is called a DMZ (DE-Militarized Zone) which basically takes it out from behind the router's firewall.  Before the update the manual IP address was in my DMZ.  After the update I had the MTU problems.  Well after troubleshooting everything else, I reset my 360's network configuration from the console back to factory defaults.  That has my console back to using "Automatic" settings when connecting to my wireless router. Everything seems to be working fine now, hopefully it will stay that way. I would try that on your console and see if it helps.  

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Well, it was good while it lasted...the entire hour and a half.  After about 2 hours, I now keep getting kicked off live and them the "mtu error" every 10 minutes or so. Resetting my console's network settings doesn't help anymore.  And anything and everything else that connects to my router works fine.  In the only place in my router's settings that I can find to adjust my mtu settings, that amount is already over the 1364 that the console is telling me that I need.  Nothing is working

The thing that has me the most baffled is why would it work perfectly for a year and a half and then stop after the May 19, 2011 update?  The only thing on my network that is any different from 2 days ago all the way back to me first getting Live is the update from the 19th.  

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

my issue has been happening for the past month.... i am really getting sick of it, i can connect to live, but get disconnected frequently. i can not play black ops at all (server unavailable error), i start a game, disconnected, i dashboard out of a game, disconnected again...., cod 4 works fine, mw2 works fine, but black ops and bfbc2 i get server errors almost every time. i am able to play netflix and stream a movie. could it be my adaptor for my xbox? and i get diconnected from parties about every hour.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Beaastly do you know how to access the linksys config page through a web browser?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

yes, i already tried configuring everything.... i tried adding the ports and changed mtu and my ps3 has also been having connection issue, but less frequent then the box.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

if this helps.... i tried connecting my Xbox to my laptop using Ethernet cable and it worked fine, no issues! could the source of the problem be the Xbox adapter?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.