MTU error connecting to xboxlive

So ever since this morning, my xbox will not connect to the internet or xboxlive. It says I have an MTU error..... I looked at my MTU, and it's above 1364 (1500). Ive tried everything. I changed my dns settings. So idk? Should i just contact my ISP.

 

Question Info


Last updated July 4, 2018 Views 12 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

If you are not renting a router from your internet provider, you can actually fix it yourself in the router settings. If you ARE renting one, give them a call and have them fix it for you. Also, ask them to forward your ports. If you own the router, a simple google search can take you step by step for the whole process.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I tried to forward the ports, and still had no luck connecting.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I've actually had the same problem since waking up this morning. A friend of mine has said ATT is having some problems today, seeing as how i have ATT I assumed it was something on their end and not mine. Not sure who you use as an ISP but this may be the case for us both.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Well I guess i'm not the only one. I have ATT Uverse and have been doing research since about noon when I first tried getting online.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Ill let you know if I make any progress, but as of now I still cant connect =/

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Greetings ediblekids!

I've notice a couple of threads the last two days, having MTU related issues to Xbox LIVE. I do think that this comes down to your ISP is having problems at their end. Can you tell us which ISP you use.

Port Forwarding has nothing to do with MTU.

Thanks! 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Also having Uverse, doing research on my side it seems to have been a problem the last few days. I know its not exclusive to my xbox, causing me to further lean towards it being ATT's fault. My tv cut out a few times last night and a minecraft server i host crashed. According to the xbox tech support page, if your xbox has run fine before and suddenly you receive this error, the only thing to do is wait it out.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

@Taidara, I am on ATT Uverse. And I see others have the same issue.

Thanks for y'alls help

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Jeez I thought I was alone in this problem but I guess not!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Just a heads up, I contacted my ISP, and said nothing is out of the ordinary. And nothing was done to help. -__-

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.