Most bizarre controller problem you will ever hear of......

long story short, i bought a mini pro ex wired controller new from walmart, came home and started playing nhl 12 vs mode online.... played about 7 games and then in the middle of the 8th game, i turn the puck over and hit right trigger to change players on defense and nothing happens.... i press it a few times and still cant change into the player on my team closest to the puck. My opponent then turns it over to me, i become the guy with the puck obviously and hit right trigger to pass and it works... i pass a few times in a row and assume it was just glitchin or laggy or something when i couldnt change players and keep playing. Next time he has the puck it happens again and i cant switch players.... anyways, i lose the game and im scratching my head wondering wtf is going on. i go to my friends list to see if anyone who might know whats up is on, and i go to use the right trigger to scroll down and it works just fine.... i go to a few different lobbies to see if right trigger works fine and it does, on different games, netflix, whatever... the only time right trigger doesnt work is when i dont have the puck playing nhl 12... or so i thought, i popped in nhl 11 just for **** and it did the same damn thing...... my mind has been blown for hours wondering how this is possible... i tried uninstalling and reinstalling, i tried using both usb ports, i tried letting the xbox chill and turned it off for an hour, i returned that controller and exchanged it for another of the same kind, and the new one still does it.... i turned on my old wireless controller and right trigger works just fine.... freakkin bizarre !!!! anyone got an idea just wtf this could be ?

 

Discussion Info


Last updated July 4, 2018 Views 3 Applies to:

Yeah I got an idea. The triggers use potentiometers to determine how far a trigger is pulled. Most games only require around 70% to get full response for action and the dashboard and menus probably only around 20-30%. This third party controller might no be sending the full or near full signal the game is looking for.

-

Seeing as it licensed for the 360 not sure how this could happen though unless they didn't properly design it to spec.