Manual wired IP address changes on its own

I've been playing wirelessly for the past couple of days and decided to go wired instead. I went in the settings and chose the IP address, subnet mask, and gateway that I wanted. Immediately after I enter these values in, I'm given a different IP address and subnet mask. It still connects to the Internet and Xbox Live but the network speed is significantly slower. I have attempted to set a manual IP address repeatedly and this happens every single time.

 

Question Info


Last updated July 4, 2018 Views 2,926 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Greetings Jackaveli!

May I ask, do you need to assign your console with static IP? And if so, what's the reason for this?

To always be sure that your console receives the same unique IP address, assign your console's MAC address in the DHCP server on your router, to "reserv" an address and choose an address outside of the dynamic range of your DHCP. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I couldn't find this topic. It was buried under so many lol.

I assigned my console's MAC address in the DHCP server on my router and the Xbox One is still overriding my manual IP and giving it an automatic IP. The only time the manual IP sticks is if I'm playing wirelessly. That's fine for when the console isn't in my bedroom but when it is, I prefer to play wired because my speeds are faster and my latency is lower.

If it's of any assistance, I'm using a Netgear Wireless N 150 router, model number WNR1000v2.

I click on LAN Setup under the Advanced section.

I have "Use Router As DCHP Server" checked.

I reserved my Xbox One's address.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Quick Question.  Are you using the same MAC address?  If so, your wireless MAC address is different than your wired MAC address.  Look it up and change it in your Netgear router.  If you want the same IP address you were using, you will need to change the MAC address for that IP (Routers won't allow you to associate 1 IP address with 2 MAC addresses).

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am seeing this EXACT same problem. I was using wireless then want to switch to wired.

I can not get "manual" IP setup - it never takes, and I know what I need to do on the router, the different MAC address for wired, etc.

I end up getting a really strange IP always too...my router should assign 192.168.0.xxx but the Xbox ends up getting something like 168.254.38.106, even after I setup the manual IP address for wired.

(reason to go manual setup, btw, is so I can get NAT open)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Adam,

The IP that you're getting is what's known as a Reserved Private Address and will be on the range of 169.254.x.x. This occurs when the static IP doesn't take and the device (in our case, the XB1) can't retrieve a valid address from a DHCP server.

If this is occurring, it suggests that either the XB1 networking configuration isn't being recognised or that the manual configuration is taken, but the XB1 defaults back to DHCP after it fails to contact the gateway.

Either way, there's two method's to assign a static IP and if the MAC has been configured in your router for a DHCP reservation, then there shouldn't need to be any configuration at the end device. You should only need to configure a static IP address on the XB1 if there is no DHCP reservation on the router and you're trying to assign an address OUTSIDE of the DHCP range.

i.e. DHCP Range is: 192.168.1.1 - 192.168.1.99

     But you want the XB1 to be 192.168.1.100

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I recently called Xbox One Networking support to see if that had any input, what a waste of time.  I am a network engineer, and can tell you I have experienced the following:

While playing BF4, I will get randomly kicked back to main screen "lost connection EA servers" type error message.  My wife will watch Netflix with the kids and she will get the "connection interrupted" type message.  I can play Forza5 no problem.  All of my other devices, phones, laptops, tablets, etc, never have a problem.  In fact, I streamed a movie from my iphone5 last night over the a website, NOT ONE HICCUP.

So I decided to start using the wire, and need to use a Static address, or DHCP reservation.  My router at home does not support uPnP, as it's an enterprise level router.  With that being said, i have to manually configure static NAT statements.  When I tried to manually assign the IP address on the Wired connection to 172.16.201.19 255.255.255.0 172.16.102.1, it would not take and i would eventually get the 169.x.x.x address.  If I tried to manually assign my IP address to something completely bogus, say 3.3.3.3 255.255.255.0 3.3.3.1, it would ACTUALLY take, even though nothing worked.  I then decided to setup a DHCP reservation for the XB1 wired MAC address and the IP address of 172.16.102.19.  I did a DHCP debug on the router, i could see that my router recognized the XB1 MAC address, and handed out the address 172.16.102.19.....BUT.....the xbox says it's ip address was 169.x.x.x.  Seems like a bug to me, for no reason should I not be able to assign a static address, whether it works or not.

Manually assigning an IP address on the wireless connection was a breeze, not issues.  I will be connecting my xbox directly to my cable modem, (removing the LAN altogether), to see if i still experience getting dropped from BF4 and/or Netflix.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Here's my update.

I connected the Xbox directly to my cable modem, set the Xbox for automatic IP, and got the typical public comcast IP address.  No more getting kicked from BF4 or Netflix, but that doesn't solve the whole static IP address issue on the wired connection, does it?

So, I connected the XB1 back to my network, and it actually accepted the DHCP reserved address I configured on my router.  BF4 and Netflix worked like a charm, no hiccups.  I studied this extensively last night, playing BF4, and I'm now paying for it (tired).

My suggestion to anyone who is having issues with assigning a particular address to the wired connection of the XB1 would be to connect it directly to your ISP, let it get the public IP address, then bring it back to your LAN.  That's what worked for me.  Why I don't know, but the XB1 didn't like the idea of changing the IP to something within the same subnet, but once it got an address from my ISP, and then back to the LAN, it liked the address.

Hope this helps someone

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same issue. I sometimes use a tethering program and tether my 4g phone  to my xbox 360 via my laptop. I tried doing it with my XB1 and. Every time  I set the ISP to what I need, the XB1 changes it to something else. Anyone find a so,union yet?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am going to need Microsoft to answer this! I am having the same problem. I am wired to a router that I don't have admin privileges to and it is setup with a static ip and DHCP disabled. I know the correct IP Address my 360 has worked for years on it. Now on my XB1 I go to manual setup and enter the IP address in but when I finish it resets to a generic ip and it doesn't take what I enter in!!! I really just want to throw this XB1 into the garbage where it belongs.

This appears to be a bug that needs fixing.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Greetings Toasty Cracka!

Appreciate if you could create a new thread and detailing out your situation. Include any troubleshooting steps you have tried so far, so we don't post up solutions that you have already tried.

To save yourself some time, include the make and model of your router (NAT?) and your modem as well, (if this is not a single device).

[quote user="Toasty Cracka"]it is setup with a static ip and DHCP disabled.[/quote]I assume you're referring to your WAN connection type?!

Thank you!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.