Low performance after connecting xbox360 with my new TV set

Good morning every1

I m owner of an xbox 360 and it was connected with my old CRT tv set with the official cable av - .

Few days ago I bought a new tv set (LG 42LW650S) and I connected it with the same cable but I changed the position of the switch from TV to HDTV and the connection to tv is with 5 cables (component). Everything seems to be perfect but when i tried to play PINBALL FX2, I' m experiencing low preformance. To be more specific there is a low reaction (delay) between pressing the action button and acting of the game. Today my son mentioned to me also the same problem with SEGA SUPERSTARS TENNIS.

Does any1 know how to fix this problem or inform me about the optimal settings for  XBOX360 with a HDTV.

Thanks in advance

 

Question Info


Last updated July 4, 2018 Views 0 Applies to:

You might want to try with an HDMI cable. See if that will work better.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

well my friend i would have, tried that but i didn't for 2 reasons, first is that from my point of view  the problem should be at the prossesing unit of graphic display or something there, and second thing is that my XboX has an AV output not HDMI and i have to buy cable that costs aprox 25 - 50Euro.

ps my xbox dosen't have an HDMI output only A\V

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Babas GR,

Many of the new tvs offer settings to help accomodate performance while using your Xbox. This is typically called Game Mode. I did find a post regarding your particular make and model and it looks like it is a common issues.

lgtvs.techstuff4you.com/.../input-lag-lg-lw650s-game-mode-hdmi-1-renamed-to-pc

I would make sure you update the firmware of the TV as it looks like even in game mode people are still having issues. Good luck.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Kraused,

you do realise the thread is over a year old.  PLease look at time stamps prior to posting.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.