Linksys WRT54G2 Problems

Alright,  I have a Linksys WRT54G2 Wireless Router..... I have owned it since I believe end of 2009,  The router has worked perfect for me all this time till here for the past week I just got my Internet back after a month of not having it.  The whole time the internet was off,  my router stayed on,  Didn't really bother with disconnecting devices, turning the power off to it or anything, I left it alone like it was.... Well I got my internet back.... All my devices connected fine as usual before it was disconnected... Ok so I use my computer for awhile then I turn it off, then later on I'll turn on my xbox and try to connect (wired) it wont connect at all?  Possibly a IP conflict,  I try the laptop (which I connect wirelessly as always,  same problem. So I reset the power on the router.... everything connects good as usual, but if i turn the xbox off and back on to reconnect, it wont reconnect for some reason, same thing with the laptop,  Ok so I tried something different.....  I hard reset the router back to Factory default settings,  and hoping it works,  still same issues. To sum it up pretty much,  the devices that I want to connect have to be connected right then and there after the router is powered on, and my connection will stay on until I turn my devices off and back on and they wont reconnect with my router unless its reset.

When I bought the router over 2 years ago,  I never had to configure it,  I leave it unsecure since I live in a rural area pretty much by myself,  and I live by myself.... I have never had no problems with it till just this week.  Im pretty clueless on what to do,  im thinking the router is starting to be a faulty router?  Not sure. Everything use to connect fine to it with no problems at all till I lost my internet for a month and I received it back,  I started having all this trouble, and if anybodys wondering,  none of the settings were touch on the router the whole time, nor was the router ever touched while my internet was off. If anybody has a clue whats going on,  reply back so I can figure this damn thing out! Its frustrating me to the max!

Appreciate the help guys!

- Sim31

 

Question Info


Last updated July 4, 2018 Views 3 Applies to:

Hey Sim :) Have you tried restarting the modem as well? Also, are you able to connect right after the disconnection by testing your network connection? (Guide/Far Right Blade/System Settings/Network Settings/Test Connection to LIVE)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Its the modem thats the problem. Reset your modem.

Sometimes if you have cable internet, the company will send both cable TV channels and internet even if you did not order cable TV. That will confuse routers and modems. Call your internet provider and they will come and install something called a splitter.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.