Launch and exit apps has a black screen for 5-7 secs

My Xbox when launching any of the apps ( Netflix, youtube, xfinity ) always shows a black screen for about 6 secs before the splash screen comes up. First its the splsh screen with just the logo and then it changes into something where it indicates its trying to load something.

In all it takes about 15-20secs before i get to the actual app content. I have a few questions

1) Is the black screen normal? it looks like a fade-in fade-away screen so looks deliberate ( i got a replacement xbox and that performed similarly)

2) Why does it take so long for a app content to load, are the xbox consoles not powerful enough to start up a app faster? ( it plays high graphic games so am surpised it cant do this simple task)

3) Why show a normal splash screen and then show something updating ( why would anyone want to see the splash screen when its doing nothing behind the scene)

3) Are we going to get multi tasking support, its sooper annoying to start all over everytime u want to switch apps.

 

Question Info


Last updated July 4, 2018 Views 0 Applies to:

Hey Hollow, if you're seeing this across multiple consoles, then it's likely normal for the app to behave this way. :-) You are welcome to try the steps provided by Mister Darcy, but I'm afraid we don't have any information as to the 'why,' as to the splash screen, aside from what Mister D. stated previously. Let us know if you have any other questions we can help with!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have seen this happen even in other consoles so am not sure if the refresh will help. I would still like to understand why it takes the time. Its not the internet as i see it happen when i launch and exit dvd or games as well.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Greetings, HollowSmile! Sometimes it takes few seconds to load before an app launches. You might try clearing your cache to re-download any updates by following this guide: support.xbox.com/.../clear-system-cache. Alternatively, if you are using a wireless connection, you may want to take measures to improve the strength of your connection:support.xbox.com/.../performance. Taking these steps should improve your overall experience. Hope this helps!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.