Issues with startup screen with hard drive and corrupted profile

When i start up my xbox (with harddrive) it stops at the startup logo screen. After a few minutes or so it will bring me to the create profile page.
 I try to download profile but no storage device is found. However when i remove the harddrive it starts up fast.

Just recently i found my xbox live profile to be a ''corrupted profile'' or something. I have never hacked and my xbox is not modded in any way.
I searched online for answers and i decided to delete my profile (but keep all saved files) and try to download it back. I was not able to download my 
profile back, it gave me some error message something about not being able to retrieve profiles at this time so i decide to do it later.
Which brings me back to the startup logo screen. I most definately want to keep my saved files as i have put a lot of effort into them. What can i do?
 

Question Info


Last updated July 4, 2018 Views 3 Applies to:

Have you tried clearing your cache or checking for corrupt files on the hard drive? See the link below for steps on how to clear your system cache. Also look for corrupt files on your hard drive you will see a triangle with a ! inside of it. If you see any of those delete them. Here is how to - support.xbox.com/.../clear-system-cache

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yeah i did that before, now i just get stuck on the loadup screen.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey there Tofu! Are you able to download your profile on another console, or you console with a different HDD attached? It seems your console works fine without this HDD attached, maybe there is something wrong with it. Let me know, thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.