Intermittent problem connecting to Xbox from Windows 8

I was chatting with Xbox support today and they asked me to talk also to windows support. After chatting Windows support they suggested I post my problem to Xbox Forums ... so here I am.

I have odd issue with my account - In Xbox 360 all is fine, I can log in anytime with no problems, but with Windows 8 games, sometimes game logs into Xbox fine and sometimes it gets stuck in "logging in" prompt and never gets a timeout or error message. The Windows 8 Games app seems to be always able to log in, but games sometimes log in and sometimes do not.

I found some article that this might be happening if account is in one country and user in another Country, or if the timezone is incorrect. 

I am located in Ireland and my account is set to be in Ireland ... Windows locale is also set to "English (Ireland)" ... so this "should" not be an issue here.

The account has not always been an Irish account. It started out as Finnish account, then was UK account for some time before final movement to Ireland. I did the account location swap from UK some time ago (cannot remember when exactly) - could this be causing it somehow? A side note - I sometimes end up at  /en-GB/  pages instead of  /en-IE/  pages at xbox.com or even http://support.microsoft.com/?ln=en-gb

 

Question Info


Last updated July 4, 2018 Views 3 Applies to:

Hi Ex6,

            Sounds like you've done a pretty through investigation yourself already.  I would just check what location settings you have set on your xbox console and registered account for xbox.com along with your Windows 8 location settings and ensure they all match up.  Could be there is a mismatch somewhere and its not happy.

Bit of a wierd one that, as a tester myself its the edge cases like this one which are the interesting bugs.

Hope you find the issue.

Regards

BoA

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Xbox console was set to UK (changed now to IE - but this should not matter as Xbox is working fine).

live.xbox.com/.../BillingAccountInformation shows Ireland.

Windows 8.1 shows "Country or region" - Ireland.

Time is also correct: "This computer is set to automatically synchronize with 'time.windows.com'."

(IMHO the timezone / location thing should not "really" matter to Microsoft, as people do travel, either to other countries or inside one bigger country with multiple time zones)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey there Ex6,

Sorry to hear you've been having issues using your Windows 8 Games app.

Sometimes region transfers can take up to 90 days to process. I'm not entirely convinced on that one since you are able to sign in on your console. If you would like to look into that further, you would want to contact Phone Support to check the status on the transfer.

This may be specific to the 8.1 preview, in which case I would post on the 8.1 preview forums for some further support. Our PC gurus may have some more detailed support suggestions for you.


Please keep us posted on how everything goes.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Update... Very strange thing I noticed today. I was playing around in my Windows 8 system and decided to try the "change secondary account in the machine as "child account".

So little later I got automated email from "Microsoft Perheturva <*** Email address is removed for privacy ***>" (thats Finnish language for "family safety")

So why does the message come in Finnish language? Fair enough the account used to be Finnish to start with, but then it has been migrated to UK account and after that to be Irish account.

And last time I chatted to MS support about this, they said they see no problems or connection to Finland/UK with my account. Apparently they did not look deep enough :(

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey there Ex6! That definitely is peculiar. It's possible that when they checked your account with you and saw no connection to Finland/UK, they didn't look for any child accounts that were tied to your account. It might be worth it to chat/call them again and tell them about the weird email name you received.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Cerb,

Let me clarify a bit. I did not have child accounts in past when I discovered the odd problem.

I have 3 users created in my Win 8.1 top. Me as administrator, wife and child as standard accounts. Now few days ago when I changed in my laptop one account rights from normal user to child account I got the "welcome letter" in Finnish.

That to me tells that not all MS internal user related databases are synchronized to the latest info (that the account owner is in Ireland) and from some (old, forgotten, not in sync) database some MS products/services still sometimes get the info that this is Finnish account. And I believe that ultimately this is causing also the initial problem, that some Win 8 games are unable to log into Xbox Live.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi there Ex6,

Please check your forum PMs when you get a chance. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.