Incredibly low bandwidth usage while downloading

I've got my Xbox One connected to ethernet and I usually get anywhere from 100 Mb/s to 1 Gb/s on my PC. Currently, I've spent over two weeks trying to download Halo Master Chief Collection and the bandwidth never raises above 400 Kbit/s with the average I see being closer to 15 Kbit/s.  

Everything else runs fine, I can stream in HD on Twitch and Netflix with no issues, multiplayer in Advanced Warfare hardly ever hiccups, I just can't get the download speed to raise to appropriate levels. It's not only with the Master Chief Collection, I can't even get good speeds with any games from EA Access. 

I've switched from wifi to ethernet, tried canceling the download, restarted the Xbox multiple times but to no avail. 

Also, these are digital downloads, not disk downloads. I had no issue getting Advanced Warfare installed.

 

Question Info


Last updated July 4, 2018 Views 204 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

My guess is that you'll have to change your DNS in your network settings from the default to either Google DNS or Open DNS

Google DNS:  8.8.8.8 and 8.8.4.4

Open DNS: 208.67.222.222 and 208.67.220.220

You can find the network settings by

  1. pressing the home button
  2. Press the menu button right of the home button and go to settings
  3. From there you can go to network
  4. select advanced settings
  5. DNS

After that perform a powercycle




But just for troubleshooting sake can you also fill in the following information as accurately as possible if the above method wouldn't work

What Country/State/Province do you live in? 
Modem brand & model number: 
Router brand & model number:
How many Xbox 360 and Xbox One consoles are connected to this router?: 
Wired or Wireless (for each console): 
Things you have tried: 
Is UPnP Enabled? Yes/No/Unknown:
Do you have a NAT error? If so, what is your NAT type?:
Any Error Codes you encounter: 
Who is your ISP? (Internet Service Provider):

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Changed the DNS and did a powercycle, didn't seem to do anything for the download speed so I canceled the download again and retried.

This time, it got through to about 15% with speeds around 100 Mbit/s and up but then the download got queued very briefly and the speeds dropped back down to around 5 Kbit/s when it got to 15%.

I wasn't doing anything on the Xbox and was just letting the download run.

I'm at Georgia Tech so I can't answer most of the troubleshooting questions but I'll answer what I know.

What Country/State/Province do you live in? : US, Georgia

Modem brand & model number: N/A

Router brand & model number: N/A

How many Xbox 360 and Xbox One consoles are connected to this router?: 1

Wired or Wireless (for each console): Wired

Things you have tried: Hard reset, changed from wireless to wired, DNS change, canceled and retried downloads, paused download then restart xbox and continued installation.

Is UPnP Enabled? Yes/No/Unknown: Unknown

Do you have a NAT error? If so, what is your NAT type?: Open

Any Error Codes you encounter: None

Who is your ISP? (Internet Service Provider): Georgia Tech ResNet

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Just tried again to download a different game, Titanfall. The download went smooth for about 20 minutes, got 54% completed with the bandwidth staying steady at 50-100 Mbit/s. Once it reached 54%, the bandwidth speed dropped down back to around 5 - 50 Kbit/s.

Now the download keeps switching from saying Queued and Installing with nearly no progress being made and the download speeds staying low as if no activity.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Can you check if it's trying to also download updates at the same time because this can give issues with the update not finding the game since it's not fully download/installed

Since your NAT is open it shouldn't be giving this many issues

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

How can I check that? These are digital downloads and nothing prompts saying they're trying to update.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Have you checked with everything on this page yet ?

support.xbox.com/.../troubleshoot-slow-game-or-app-downloads-on-xbox-one

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yeah, I've attempted everything on that page and nothing has changed.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Here's my detailed network statistics if it helps.

Download Speed: 395.42 Mbps

Upload Speed 12.07 Mbps

Packet loss 0%

MTU 1420

Latency 70 ms

Here's the bandwidth usage while Titanfall is "installing", I'll all values I see for the next 20 seconds.

795.0 bit/s

267.14 bit/s

162.16 bit/s

12.79 Kbit/s

1.16 Kbit/s

1.38 Kbit/s

5.84 Kbit/s

4.7 Kbit/s

etc.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I assume your connection is not being routed through a traditional residental gateway, but through a campus network?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

That's right, here's a link to explaining the campus network if it helps: www.oit.gatech.edu/.../campus-network-gtnet

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.