Inconsistent/Non-existent Wireless Connection

Okay. This is going to be a lengthy post, so bare with me. 

I bought an Xbox One about a week ago and have been having connection problems since I first set it up. It seems to have trouble maintaining or even connecting to my wireless. Now I am using the **** TG852 from Xfinity which I know had problems before. I have called Xbox support and the guy spent four hours with me to get me connected to XB Live. We had to do a system restore and it finally worked until I went to play titanfall. I could not maintain a good connection to stay in a game or even connect to a multiplayer match. When I did the training session, it would be fine for about 2 min, then lag for about a min, then repeat. Then the power went out a couple of days ago and  now it wont connect to xbox live again, just like before. I was supposed to talk to the same xbox support guy again, but he didnt get around to calling me yesterday and he only works on weekends, so I figured I'd see what you guys think.

Here some info that might be helpful:
-I cannot connect wired as the router is at the other end of the house 
-Xbox connects normally on a wired connection (through my laptop)
-All other devices in the house work fine and some even further away from the router
-My brothers xbox 360 (not turned on at the same time) connects to live just fine although I havent tried it in the exact same location.
-PS4 (also not at the same time) connects just fine wirelessly
-NAT is usually Open except after the power went out
-Wireless strength is consistently around 67-70%
-Latency is consistently around 80
-Port forwarding and triggering are disabled (as the support guy told me to do)
-UNCP is enabled
-Xbox is on a self and not in an enclosed entertainment center

From the multiplayer detailed tests when I could connect to live, I found the connection to be inconsistent. During 5 tests, 4 came back with 12Mb/s download and 6 upload with 0% packet loss. One came back with .87Mb/s Download and 6 upload with 1% packet loss. 

So anyone have any ideas? Why is it that this device is the only one giving me trouble?

 

Question Info


Last updated July 4, 2018 Views 37 Applies to: