I have sound but no picture?

I have an xbox 360s 250gb, manufacture date 23rd October 2010, Using old cathode ray TV that has and still continues to work fine and the cable that came with the xbox.

When I switch on the xbox I can hear the audio and use the controller to navigate menus, switch off console etc,  but there is no video. The lights on the front are green and appear normal.

I have disconnected the cables and ensured they were inserted correctly, tried the xbox on other scart sockets, reset the display using Y and right trigger. I have tried a friends cable to.

Any advice would be appreciated.

Thans

 

DA

 

Question Info


Last updated July 4, 2018 Views 1 Applies to:

Hopefully something in here can help, but it sounds like you have pretty much tried everthing.

I had the same thing happen to an old unit of mine, I tried all the steps you have listed and nothing worked.
Turned out in my case the GPU had died, so it was either repair or replace for me.

Unless someone has some further steps you can try you may need to ring support and order a service/repair.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Can you try with a different TV?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.