I have an Open Nat type but I still get disconnected from online games. PLEASE HELP!!!

What Country/State/Province do you live in? U.S.- GA
Modem brand & model number:
Router brand & model number: linksys- wrt54g v4
Network Connection Type: Wired
Things you have tried: Port forwarding
Is UPnP Enabled? Yes
Is NAT Type Open? yes
Any Error Codes you encounter: not sure what this means
What type of internet do you have? Cable/DSL/T1/3G?
Who is your ISP(Internet Service Provider)? Comcast
When you run "Test Xbox LIVE connection" what is the exact message shown on screen? there is no message, after about 5 seconds the bar fills about 1/3 full and then after another 5 seconds it fill the connection bar completely.

This has been very frustrating for the past 2 or 3 weeks. When i play black ops, i will be about half way through a game and it will show the disconnecting icon (Ethernet cable being pulled out) and then it will take me back to the lobby but then it will say game lobby closed. I then can go to my recent players list and see that they are still playing on the same game. I would says this happens 4 out of 5 games. When I play fifa 11 at night, I will be in a party with some guys and we will be playing a "pro clubs" match and it will just randomly say "lost connection to host. this game session has ended" and take me back to the main page. it also kicks me out of the XBL party. At first I though it could have been my Ethernet cable, but then the other night I was video chatting on my macbook using the wireless and we kept getting disconnected at the exact same time as when i would get kicked from a Black ops game. This leads me to believe that it is the actually internet or something of that nature. Any help will be much appreciated.

 

thanks

 

Question Info


Last updated July 4, 2018 Views 4 Applies to:

Ant is Correct if you have a WRT54 anything Upgrade it.

this will fix your problems - as it did mine.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Have you contacted Comcast yet? You have done the troubleshooting there to determine it is more than xbox live, since your Macbook got disconnected - it will then be related to your internet connection or your home networking equipment.

You may want to plug directly into your cable modem instead of to your router, if you still get disconnected from xbox live then you'll want to have Comcast take a look at the signal, maybe even have them swap out your cable modem. If you're not getting disconnected when plugged directly into your cable modem then most likely your WRT54G is having the issue, which is kind of an older router - I had the WRT54G V8 for several years before I replaced it this past January, so the V4 is possibly at a point of failure.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi, can you tell us  the make/model of your modem as well? Have you tried powering all of your kit down and leaving off for a few mins, then starting up the modem (wait 1 min) then start up the router

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.