I can't connect, yet it says everything's fine.

For the past few hours I've been trying to connect to Xbox live, but it just loads for a few minutes, then says the usual message when your internet isn't working. However, my internet obviously is working, and the test connection thing shows that it connects to all of it fine... I have no idea what to do, considering nothing like this has happened before. I've tried unplugging everything, restarting my router, and still it doesn't work. It was working perfectly fine, then I left for a few hours, and when I came back I couldn't connect. I know I'm not out of membership or anything, because I should have atleast another 6+ months.

If anyone has any ideas or a solution, I'd greatly appreciate it...

 

Question Info


Last updated July 4, 2018 Views 0 Applies to:

Are you attempting to connect over wireless? Try plugging the console directly into the router or modem. Do you still have issues?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same problem, it is like someone hacked the profile.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey mate, I don't think you need to be concerned about your profile being hacked, especially if you've NEVER shared your login information. Please answer these questions, so we can help investigate your issue.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.