I can't complete some functions when in xboxlive.com due to a weird Silverlight issue.

For instance, when attempting to access the avatar editor from my computer while on xbox.com, it will load up to 99% and then a pop-up screen will appear with an exclamation point and the following message, "This application was created for an expired beta release of Silverlight. Please contact the owner of this application and have them upgrade their application using an official release of Silverlight." Since I did not create the app on  xbox.com, shouldn't they upgrade this on their end? How do I troubleshoot? 

 

Question Info


Last updated July 5, 2018 Views 20 Applies to:

It's working fine for me. Make sure you have the latest version of Silverlight down at your end.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have been having this problem lately and cannot find an answer. I do have the latest versions installed and am on IE9. The problem wasn't always present untill recently.  The video on the main page is gone and certain pages with silverlight elements do not show. I cannot see any of the avatar editor, but I can hear the music. I've tried reinstalling silverlight already, please help.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey Shadow! Have you tried clearing the browser's cookies and cache and restarting it? Also, maybe try deleting Silverlight from your computer completely and re-installing it then. Does this help? Thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Uninstalled everything "Silverlight," cleared browser, and restarted PC. Then downloaded the plugin and SDK, installed both, and went to xbox.com.  Same problem :/  Using IE9, compatibility mode messes up too.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Does this happen with any browser you try using?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This happens to me too. When I first went to the avatar editor page all that was on it was the "down load Silverlight" icon. When I did that it said I already had it installed. It still didnt change anything. So I uninstalled it and re-installed from the avatar editor page. It installed successfully. I re-booted but still, only the Silverlight download icon is on the avatar editor page, nothing else. What is going on here?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey Waffle Girl! What browser are you using to access Xbox.com? Have you tried other browsers? Also, try clearing your browser's cookies and cache and then try again. Let us know, thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Mr. Gwyther, Still not working. Have cleard cache etc.. since last we spoke in December. My broser is IE9. I have not tried a different browser yet, has anyone had luck with that? Why would IE9 cause this problem? And what is the Avatar page supposed to look like anyway?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Issues like this are typically caused by the user's PC, either something not installing properly or settings preventing it from functioning properly.  Gwyther wanted you to try another browser to try and narrow down if it's the browser that is causing the issue or if it is your PC.  I use to have an issue browsing xbox.com with Firefox, when I switched to Chrome the issues were resolved, so it stands to reason that something with my Firefox setup was preventing it from loading properly.  I never figured out what exactly caused it, I just that know it was Firefox.  So until you test a different browser, it will be difficult to determine the cause.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.