I Can Sign Into XBL, BUT My Gamerscore/Achievements/Avatar Don't Work?!?!

I've been having this problem for a few weeks. When I sign in, my gamerscore says 0, shows no achievements, and my avatar is gone. I can still play any game (but I don't earn achievements), and talk in parties and stuff. The only fix I have found is to load GOW3, then once I am into the game sign out then back in. This is the only way things go back to normal, but it is a total pain! I just want everything to be set my MW3 time.

I currently have my gammertag on a flash drive. I have 2 slim consoles. One is about a year old, the other one a month. I have used both wired and wireless connections, and have had the same problem on both consoles (which are on different networks in different locations)

Has this ever happened to anyone?!?!?

HELP!!

 

Question Info


Last updated July 4, 2018 Views 0 Applies to:

It sounds like your profile is corrupt. You would have to delete it and then recover it.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks

If I delete and recover...I won't lose anything...right?? (Achievements...online stats....?)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

No. As long as you make sure to delete only the profile you won't lose anything.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.