How To Connect to XBOX Live by using my Mac (Leopard)

Hi,

I heard it's possible to connect to Xbox Live via a computer, without using a wifi adapter. In my case, I have a Mac OS X Leopard. I have followed all the steps described here : http://support.xbox.com/fr-ca/xbox-live/get-started/connecting/mac-computer (i know it is for snow leopard, but there is not much difference in that case)

The only thing that seems troubling to me is that when I go to Apple -> Reseau (network) -> Ethernet, it is written : Not Connected, Ethernet wired but your computer doesn't have an IP adress (it's written in french, I translated it) whereas on the page I have mentioned, they have a self assigned address. Well, actually, I don't know if it is relevant..

What Country/State/Province do you live in? France
Modem brand & model number: Livebox
Router brand & model number: /
Network Connection Type: Wireless/Wired : Wired to my computer, wireless from my computer to my livebox
If Wireless, what type of encryption are you using? /
If Wireless, are you using a white or black external adapter, or an internal (Xbox 360S) adapter? /
Things you have tried: I tried to turn off then turn on again my computer, same thing with my xbox 360
Is UPnP Enabled? Unknown
Is NAT Type Open? Don't know
Any Error Codes you encounter: W : 0000 - 000B X: 8000 - 040D Y: 0000 - 0000 Z: 0000 - 0000 ID: 0001 - 0002  sometimes ID: 0001 - 0003 or 0006
What type of internet do you have?  ADSL
Who is your ISP(Internet Service Provider)? Orange
After you run "Test Xbox LIVE connection" and click on "More info", what is the exact message shown on screen? " Impossible de se connecter à votre matériel réseau à partir d'une adresse IP statique " (if I try to translate : "Can't connect to your network device with a static IP address")

Thanks,

Stan

 

Question Info


Last updated July 4, 2018 Views 5 Applies to:

In step 6 of that guide, it mentions setting the IPv4 settings to off. If you're computer is saying it can't find the IP address, can you double check that setting to make sure that it's actually set to off?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yes IPv4 settings are off.

However I also have the IPv6 settings, which are on Automatic. Perhaps I have to put these off too ?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yes, try that as well. :)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Well, I tried, didn't work.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Okay, just to clarify on how your network is set up - are you using a wired connection between your internet source and your computer, then wireless to the Xbox? Or the other way around (wireless between computer and internet source, then wired between computer and Xbox)?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Xbox -> wired -> Computer -> wireless -> Internet source

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

So you're trying to run a bridged connection?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm not sure what you mean by "bridged connection". II'm trying to use the wireless connection of my computer to access the Xbox Live with my Xbox.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Alright, thanks for trying that - I'm going to do a bit of research and get back to you. :)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

You will have to bridge your connection

Goto System Preferences -> Sharing and turn on Internet Sharing. In the resulting window, select the two network interfaces you would like to bridge.

Let me know if that works

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.