HELP! gettin disconnected from xbox live

My nat type has always been open. i've never once seen it on moderate or strict. but over the last few days it keeps giving me moderate. as soon as this started happenin i've noticed i've been gettin disconnected from black ops nearly every game and sometimes it'll just lagg the whole game. and i've also noticed too it takes forever to connect up to live when i boot up my xbox. my provider is telecom and i'm usin a tp link w8960n modem...

 

Question Info


Last updated July 4, 2018 Views 0 Applies to:

My nat type has always been open. i've never once seen it on moderate or strict. but over the last few days it keeps giving me moderate. as soon as this started happenin i've noticed i've been gettin disconnected from black ops nearly every game and sometimes it'll just lagg the whole game. and i've also noticed too it takes forever to connect up to live when i boot up my xbox. my provider is telecom and i'm usin a tp link w8960n modem.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey mate, we'll need as much info as possible to help troubleshoot your issue. Please take a few minutes to read this post, and then post the necessary info in your thread.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.