Headsets not picking up voice.

Apologies if this is a repeat question, but the only ones I can find are a year or so old.

My Microsoft stereo headset suddenly stopped picking up my mic a week or so ago, I originally thought it was just my headset giving up the ghost after a good period of usage. Have bought a new headset today, and that's also not picking up the voice either. My controller says it's up to date when I connect the original Microsoft adapter, for some reason it's not registering the Turtle Beach one when I plug it in to update, but both adapters still give me sound, and incoming chat, through the earpieces.

Sometimes when I am playing a game the voice icon will flash briefly as though it's sent a burst of static, but when I speak it's not doing anything. When I start a party app there is nothing but as I disconnect and connect the mic's it flashes in a similar teasing fashion then stops.

I don't have a Kinect so that's not causing an issue, have been through all the recommended steps numerous times with both headsets to no avail. The only things I have not tried replacing are the controller and the Xbox itself!

Controller appears to be in near perfect condition, not been thrown across the room or slammed down in disgust (yet) so can't see the controller being the issue. If I end up replacing the Xbox it won't be with another one.

As you can imagine, I am very frustrated!


Any advice, tips or solutions will be gratefully received and might even stop me killing the kids...no pressure :-p

 

Discussion Info


Last updated July 4, 2018 Views 4 Applies to:

Is it the headset that the mic can be removed? If it is, make sure the mic is firmly pushed into the headset until it clicks.

Yeah checked that the detachable mic is pushed into the  headset to the max. Just unplugged everything from the Xbox and will leave it an hour or so.

Okay finally someone else has the issue I am having the exact same problem only difference in situation is halo 5 skull Candy's are my new headset and none of my other headsets (which are two of the basic xb1 headsets) none of the them pick up my voice either this problem needs to be solved I've had this problem a little over two months and nothing