HDMI video not working

I'm trying to connect my 360 (I have a slim) through a new receiver (Pioneer SC 35) with an HDMI cable, but am having problems

Currently, I have a hdmi cable going from the receiver to the TV, and a HDMI cable from the component to the receiver. It works with both my DVD player and PS3, but not with the 360.

The sound works, but all that shows up on screen are either red/blue/green/white pixels or bars.

I don't think it's the receiver, as it does work with both other components. On the other hand, my 360 works through the HDMI port if connected straight to the TV. If I have to, I'll put the HDMI port into the TV with an optical cable into the receiver, but I'd rather just use the HDMI port to the receiver. I tried plugging the RWY cables into the receiver, and that worked (in standard def) as well.

Any suggestions would be appreciated.

Thanks

 

Question Info


Last updated July 4, 2018 Views 1 Applies to:

Figured it out...now I'm just curious as to why.

When I switched my 360's resolution to 1080i (or anything other than 1080p), it works. I'm not sure what the problem is though, because my PS3 runs in 1080p when it's hooked up to the same HDMI cable -- I figure it can't be the receiver, and would have to be the 360 because of this. Is there something that has to do with the 360 causing this?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.