HDMI Passthrough issues when using HTPC

I have a home theatre PC which I was planning on using as the input for the Xbox one, however whenever I plug it in, it doesn't seem to work right.

For instance the screen will load (eventually) but have quite a few artefacts on and if I try to do something e.g. move the mouse, the whole screen will freeze sometimes for a long while other times it doesn't do anything until I unplug and re-insert the HDMI... rinse and repeat. Inhale tried multiple resolutions all have failed. Even my CEC adapter is being recognised (and yes I have tried it without it) but the picture is just completely non responsive.

I'm using a HDMI socket on my pc, and it uses an AMD Fusion APU for the graphics. The pc works fine if I plug it straight into my TV.

My PS3 works OK as the HDMI in, but I don't really want that going into the input due to the slight lag it would introduce. This isn't an issue for general media.

 

Question Info


Last updated July 4, 2018 Views 169 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I'm having a similar problem. If I run live TV in Windows media center it works OK. If I drop out of wmc the screen will freeze. There are no issues if I plug the PC directly into my TV. The freezing is completely on the xbox one side.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Same deal here.  It will freeze up on you if you don't have WMC playing tv or video.  

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am seeing this as well. I can get the picture to move if I unplug a USB mouse. It moves for about 3 seconds. Then another freeze. Unplug the mouse and it starts for another 2 seconds.

I've never seen such weird behavior

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I use the hdmi in with my x360 and have noticed a very slight lag.  Is there anything that can be done about that?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

No, that slight lag is unavoidable. It's been publicised in the past that consoles can be passed through but the experience may not be optimal.

My issue is complete freeze ups that can only by fixed by a pc reboot, hdmi re-insert (though this lasts a matter of seconds only) or by somehow already having media playing. This is quite difficult in reality as you have to be able to see what your doing to select some media.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am having same issue. Is it an hdmi problem?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same issue. If I plug the hdmi directly to the tv input there is no pause. The problem is in the passthrough of the video, maybe it's splitting system bandwidth. I hope they fix it soon.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I can't passtrough dts or dts hd trough the hdmi in. Do you guys have  the same issue ?

I have an htpc running win7 with xbmc. It works fine when played directly to avr. When plugged in xbox one, win 7 tells me that the sound device is only compatible with Dolby digital.  

I use an ati 7850 hdmi out to Xbox one.  Is there a driver to download or anything I can do ?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I don't know about DTS audio, but I don't have any problems at all with my HTPC HDMI out. I have a 7950 boost set to 1080p at 32 bit color. I can work with the desktop just fine.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

@kreep if you check in your some device proprieties do you see dts and Dolby ?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.