HDD rejecting only my profile

A few nights ago  I was playing Brotherhood online and the game said the memory device storing your profile has been removed, even though it obviously wasn't, since I wasn't signed out. The next morning I tried to sign in and my profile was nowhere to be found. So I tried recovering it, and apparently there was a problem recovering it to the hard drive so I put it on a memory card and tried moving it to the hard drive, but it keeps rejecting my profile. I can move my borthers' about freely, but mine isn't working. Also, it's a very old hard drive, came with one of the original xboxes, but I find it hard to believe that because its old, its just not working.

 

Question Info


Last updated July 5, 2018 Views 0 Applies to:

So you removed the HDD and used a properly formatted USB device and it still didn't work? What happened?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.