having problems with live

i seem to be having a few issues with xbox live,zune and marketplace.

 

ive been having problems downloading content from marketplace,as well as zune.these issues are new,they have started around the time i installed a router and created a wireless network.i followed the faq in these forums to change my nat settings to open.this seems to have fixed,the error messages with dlc and zune.the reason i noticed was purchased dlc that,i had to redownload,after a error message on zune.being unable to watch zune i rechecked everything after the install of the router.it seems that i was unable to watch zune or download content from live,with medium nat.

 

 

but they seem to have created another issue,im often signed out of xbox live now.for no aparent reason.i could perhaps be playing a game for 15 min and be signed out of live.or perhaps i could be idle on the dash for a legnth of time and get signed out.being signed out isnt a problem,signing back on is though.i cannot sign in normally after this happens,i cannot reconnect to xbox live,i need to sometimes recover my gamertag or shut down my 360 and manually reconnect my network.

 

 

so i duno what to do to fix it.if someone can understand my ramblings and offer a suggestion id apreciate it .

 

my concern is that i cannot see a reason i would disconnect from xbox live,and having to do an account recovery is scary.not that anyone is stealing my account.has there been anybody else with this weird type of problem,and any way to fix it perhaps?

 

Question Info


Last updated July 4, 2018 Views 3 Applies to:

Do you use any Turtle Beach headsets or other 3rd party adapters? If you do try unhooking those and trying again.

How far is your xbox from the router?

Are you using a 360S with an internal adapter or a 360 Classic with an external wifi adapter?

If it's external then is it the G (White) adapter or the N (Black) adapter?

How much signal strength do you have on your wireless network? (They fill in left to right)

What router did you set up? (Brand and model)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.