Have to keep restarting router to solve MTU problems (Belkin router)

Hi guys, me again - thought I had this sussed. I cannot get on to Xbox live and less I do a soft restart on my Belkin N router - as in, clicking "Restart Router" from the IP settings page, not by switching it off at the plug and turning it back on again.

 

Once I've done the soft restart it then signs in no problem - otherwise it won't do it. I can't find the MTU setting in my router config as it's cable and the connection type is dynamic. On my friend's Belkin, he has ADSL and I can se the MTU settings in the PPPoE section.

 

Any ideas? I don't want to have to keep booting my PC up to soft restart the router everytime I want to sign in. I've been using Xbox live for two and half years with the same wireless set up and Belkin router and never really had a persistant problem like this!

 

Help! Thanks!

 

- Rory Skywalker

 

Question Info


Last updated July 4, 2018 Views 74 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi, its a common issue with Belkin N's try setting it up exactly like this:- www.unofficialguidetolive.co.uk/.../62-my-nat-is-strict-or-moderate

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Shad0wmanUK - thanks for this but it hasn't worked. I have to restart my router EVERY time in the IP settings page to get it to connect. Keeps saying the MTU isn't high enough otherwise. This is SO frustrating as it used to work fine. I did lower my broadband from 20mb to 10mb - would this have anything to do with it? The two seem to tie up or just coinscidenc? Hope you can help!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Your with Virgin then yes? They do have some issues with Live at the moment but I wouldn't expect it to show up as MTU really. You can prove its the Belkin by connecting direct to the modem as a test (you will have to power off the modem before swapping it over to the Xbox).

 

If it works ok with a direct connection you know Virgin is fine and its the Belkin. What is the exact model of Belkin it will be printed on a sticker underneath and starts with F. Also what firmware is it running?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I updated the firmware yesterday and that seems to have made no difference. My problem with testing it directly is that I have NO ethernet cable downstairs. I suppose I could hook it all up in the spare room - a bit of faffing about but, as you say, it could highlight that it's the Belkin. I'll test it later today - as for the model number, I'll let you know about that, too! Thanks so much for your help so far!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yep please let us know

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I think we may have got there. I plugged the Xbox into the modem directly via the ethernet and it connected to Live straight away! I then took it back downstairs, hooked it all up again and tried to get it connected wirelessly. Failed - this time saying something about a DNS server error. The PC upstairs also said "There's a conflict of IP address with another device on the network" - the Xbox? The connection test results then said to restart the router by turning it off and on again - I did this at the plug (not by restarting it in the config settings page). I then powered the Xbox up and VOILA! Connected to Xbox live! I then turned it off and tried again - no problem, connected within seconds. So - first of all, I think we got there and second - WHY/HOW did this work (ie connecting it to the ethernet directly etc) - does it reset the IP address or confirm it or something? I'm dying to know how/why you thought this would work so I can bear it in mind for the future! Thanks again, Shad0wmanUK - look forward to hearing from you! - Rory Skywalker

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,.

 

Well connecting direct to the modem is a basic way to connect so I would expect that to work fine it was really about proving it was the route and not Virgin. As for it working when you put it back well doing a cold boot (turning off at the plug) as opposed to a soft boot (reset via the router menu) can work wonders.

 

So how is it set-up now then? Is it set-up as per that link I posted?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Shad0wmanUk, well thing is, I'd already done umpteen cold reboots, the router/modem do not get left on, I switch it off when it's all not being used. The cold reboot wasn't helping at all, it was the soft reboot that was allowing me to gain access to Live. It's now back downstairs with the wireless adapter pluged in, Belkin PreN router upstairs and connecting. And yes, thanks for the suggested settings, I've done that, added the ".120" to the end of the IP address in the box etc. As I said, I tried it earlier twice after setting it all up back downstairs and it worked. Off out for an hour or so, will try it when I get in. Will let you know! Thanks again for all your help and correspondance so far! - Rory Skywalker

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Cool, well it should work and stay working fine if its set-up as per that link Don't forget any technology can do weird things, as long as its working now I wouldn't worry

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Shad0wManUK! I think we might have got there - will go and test it again now!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.