GTA4 disconnected from game session

I've searched ALL OVER google for a fix for this and none of them seems to work.

I can connect to every game just fine. But when I go to join a game on GTA IV, it always gives me the "disconnected from game session, returning to single player" message. I know it connects me for a few seconds because I can hear the players in the game talking for a moment before it kicks me. It never did this when I connected my Xbox directly to my modem, it started when I got my router.

I have a Belkin n450 db wireless router but I'm connected directly with an ethernet cable.

I've tried enabling DMZ and changing my Xbox IP to a static ip, but that changes my NAT to strict for some reason.

I've tried port forwarding the ports 53, 80, 88, and 3074 which seemed to do nothing.

I tried both of these solutions with uPnP enables AND disabled, it doesn't change.

I even tried disabling the router firewall and that had no effect.

If someone has another solution, I will gladly try it. GTA 4 is my favorite game. But I don't want to have to plug my console into the modem every time I want to play a game of TA4.

 

Question Info


Last updated July 4, 2018 Views 18 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Can you give us the actual model number of the Belkin? That can help us narrow things down. I've seen it before that when you enable BOTH DMZ and port forwarding at the same time (which normally isn't suggested), it opens up the NAT type on the Xbox and works wonderfully. You can try that and see if it works, but I want the model number if it doesn't to try to help you out more.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Sure, the model # is F9K1105v1

I haven't actually tried enabling DMZ and port forward anything, but I can try I guess. I figured enabling DMZ was an "open all ports" type of button.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It is, and this is why it's one of those really weird things that you never see. And I've only seen it happen ONCE and my mind was blown. Since you've tried a LOT, trying that won't hurt. So, DMZ and port forward for the Xbox's IP address, and that might help you. Let me know for sure!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Okay, I enabled DMZ again with my Xbox's IP and forwarded ports 53(TCP&UDP), 80(TCP), 88(UDP), and 3074(TCP&UDP). I did it once with uPnP enabled and once with uPnP disabled, and my NAT was strict both times.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Did you power cycle the router for 30 seconds after setting it up?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Just the router at first, but I just restarted everything, my modem, router, computer, xbox and it didn't change anything.

The changes usually apply instantly anyways. If I disable DMZ, it'll open my NAT right away, but then make the GTA4 disconnect problem again.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Well, port forwarding is the best option with Belkins, so that's perfect. The message you're getting, is it a GTA4 message, or is it an Xbox message at the bottom? And what is your firmware on your Belkin? Since it's new, I want to make sure it's up to date, there was an update this month for that model. You can see the firmware listed on the Home screen under Version Info.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Also, try port forwarding 2074 and 33078 for the Xbox, too. I found that here: www.gtaforums.com/index.php. Those are GTA specific ports, apparently.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Okay, thank you for mentioning the firmware update. I clicked update firmware on my belkin installer and it said there was no new updates, but I look and the last update was almost a year ago! This must be some kind of bug, I'm going to download the patch from the official site and see if it works. I'll report back soon.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

AHHHH. An error message!

"Upgrade file is not the correct type or version for this device. Upgrade failed. Please obtain the correct file and try again" This is the firmware file linked right there at my own routers page at www.belkin.com/.../support-product

All these posts I've seen everywhere from all the google searching I've done, it seems people have had lots of problems with Belkin. It makes me want to just switch to another router altogether. I'm gonna try to port forward those two numbers and hope it works

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.