Graphic Glitch

I've noticed that on certain newer games, I've had graphical glitches where certain items, like objects or environmental pieces, have a very obnoxious glitch where there are purple and green boxes all over the object. Example are my weapon sights in Battlefield 3, my weapons in Elder Scrolls 5, and a large amount of objects in Dragon's Dogma. I was considering this was an issue with the cable, as I'm using my default HD/AV component cable on my Xbox 360 Elite (Large, black model, 50gb or so.) This glitch is on on HDTV at 1080p, 1080i, 720p, 480p, and even in standard TV setting. Would I need an HDMI cable to fix this issue? I noticed on somebodies XBox 360 Slim with an HDMI cable this glitch wasn't present, and on another XBox 360 Slim with HD/AV cables it IS present.

 

Question Info


Last updated July 4, 2018 Views 67 Applies to:

Hi, click here for troubleshooting problems like that.  One problem specifically talks about purple and green clucters. Good luck!

E-A-G-L-E-S EAGLES!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I tried all of these, none of them have worked, unfortunatly, although I may be able to get a hold of somebodies HDMI cable in a few days for testing. Hopefully it will fix the issue. I was just hoping it wasn't my Xbox being broken, because this Elite is a trooper.

1) All the disks are clean, it happens to all games.

2) I have tried unplugging the cable to no avail.

3) I have already cleared my system cache... or at least that's what the XBox said, not entirely sure.

Thank you for the reply, at least.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Did you try using a different A/V cable?

E-A-G-L-E-S EAGLES!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I don't have another one on me as of right now. Just the one I've had since I bought the 360.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Greetings, Little M 54. If the steps on the troubleshooting page did not resolve the issue then you'll need to submit your console for a repair. You can start a repair request by visiting this page: myservice.xbox.com/.../Profileregistration.aspx.

Please let us know if you have any further questions. Standing by. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.