Grand Theft Auto : San Andreas Download "Disk Unreadable" !?!?!!?!

Today I found out they had San Andreas on  Marketplace, I went and bought 1000 Microsoft points and downloaded it. About half way through the intro just after the police show up i get an error "Disk Unreadable etc etc" So i went on the forums to see if anyone else had this problem and if there were fix's. I tried everything still same thing "Disk Unreadable", Is there any fix? If not can I get a refund from Microsoft?

Ps: I have White xbox 360 with 60GB HDD and i can play original disc xbox games like flatout fine.

 

Discussion Info


Last updated July 4, 2018 Views 0 Applies to:

Is your account a child account? Do you have family settings enabled? Did your internet go off whilst playing it? It will probably be something silly stopping it from working, i would double check everything and hopefully you will resolve your issue, perhaps popping over to the GTA forum on this site may yield better results...

Ive already tried That :/

Try deleting the game, clearing your cache and re-starting your console, then re-download it, if that does not work check your profile for any settings that could affect your ability to play the game, that's all i got i'm afraid...