Gold membership not activated on XBox live

Hi everyone,

10 days ago I subscribed a 1 month Gold membership. The transaction went well, and i received the billing@microsoft's email. However my XBox do not detect my sbuscription and when I go on the XBox live website, it keeps telling me I have a free membership.

My XBox shows me an error message when it tries to display the different types of subscriptions (it says it couldn't connect to the XBox service, but there's no error id).

What can I do ?

 

Question Info


Last updated July 4, 2018 Views 5 Applies to:

Hey there Gklems! Let's see what we can do to get things sorted.

When you go to commerce.microsoft.com, what sort of membership does it tell you that you have?

Have you tried redownloading your profile? If not, I suggest giving these steps a shot:


Let us know how everything goes and what sort of membership you're seeing and we'll work with you from there. =)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey Mister Cerb.

When I go to commerce.microsoft.com it tells me that I have a Gold Membership.

I already tried to redownload my profile, but I didn't clear the cache. I'll try it as soon as I can and tell you if it worked.

Thank you for your answer.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Gklems,

Let us know when you get a chance to try those steps Mister Cerb suggested. I would definitely try those out in the exact order he listed. It will help make sure you get an updated pull of your profile from the servers. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Unfortunately it didn't work.

Someone in the chat support helped me too and... it didn't work either... But she told me she'll talk about this to someone in Microsoft's support and they'll contact me by email when they know the cause of the problem.

If they tell me exactly what it is, I'll write it here. It might be helpful in the future.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Right on Gklems!

Definitely let us know what they find in your account investigation. What you post back here could definitely help someone else in the future. =)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.