Gamertag is invalid?

I tried to change my Gamertag to MusclesGlasses (Because I'm a huge Epic Meal Time fan) and it appears the Gamertag is Invalid. I tried to enter it in my Profile on my Xbox and it said the account was in use but when I tried searching for it using the "Find A Friend" search box under the "Friends" category on Xbox.com, it said that the Gamertag was invalid.

 

I added a space between the words and a profile popped up (lucky guy) but when I removed the space, the Gamertag was said to be invalid again.

 

My thoughts are that the last 5 letters of the word "Glasses" might be picked up by a Live censor which is used to prevent people from making racial or explitory Gamertags. 

 

I think this because my friend tried to make the Gamertag "Spicyness", but he said he could not because the censor said his Gamertag contained a racial slur. He reluctantly made "Spycyness" instead.

 

I talked to a support representative about this on the phone and he suggested changing some letters to numbers and seeing if that worked but I prefer to have just letters and keep it original. 


Any information is greatly appreciated and keep working hard.

 

Question Info


Last updated July 5, 2018 Views 6 Applies to:

Nope it's the Muscles Glasses profile that's preventing you taking the MusclesGlasses GT. To prevent impersonation the system ignores spaces when looking to see if profiles already exist with that name. It's why you'll never find someone called Vernier Slake (because I've got it) or Bucket Head Land (because you've got it).

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.