Gamerscore Tally Incorrect

This seems to be an issue I keep encountering, however the fixes that are usually suggested have yet to work, and it has now been 48 hours since I originally unlocked the achievement, but nothing has changed. On thursday (November 26th) I played game of Thrones on Xbox One, and unlocked 5 achievements for a total of 130 Gamerscore. One of the achievements I unlocked (Your Grace - Completed Chapter 7 of Episode 3 - 30g) never came up with a notification, however when I opened up the achievement app I noticed it was showing as unlocked. I then looked at my Gamerscore and noticed that it was 30gs short. My total as of today (Saturday 28th November) should be 304,469g, however it is 304,439g, so the 30g achievement hasn't added itself properly to my overall score. I have waited the 48 hours that is often recommended, I also have deleted my profile and reinstalled it on my console, hard reset my console, tried unlocking an achievement in a different game, on both the Xbox One and the Xbox 360, and also tried to re-earn the achievement, yet none of this has worked. Is there any other way I can make this unlock/update to the correct score? I play a ton of games for achievements and it is really annoying me that this hasn't sorted itself out yet, I track ALL my gaming stats now due to this having happened before, via True Achievements, my own records, and an independent  site, if you need the link on TA that shows what my correct Gamerscore should be I will post it below:

http://www.trueachievements.com/gamerstats.aspx?gamerid=431796

 

Question Info


Last updated July 5, 2018 Views 0 Applies to: