funny colours when using hdmi cable

when i turned on my xbox the other day, the picture came on, but it was all in funny bright colours, mainly yellow and green, and very bright. it is quite an old model, the white one with 20gb hd. i am using it through a matrix splitter, although i doubt this is the problem as i have been using it like this for 2 years. also, i have plugged my sons new slim 360 into the cable used for mine, and it works fine. when i use the faulty console with the standard av cable, the colour is fine, although picture quality is terrible on my 40" samsung so i would like to get it repaired. does anyone have any idea what this could be.

thanks,

Leon

 

Question Info


Last updated July 4, 2018 Views 5 Applies to:

If the cable is working fine on another console, then it would appear that the HDMI port on the console is faulty.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi RuudBullit - It appears since you've already done the troubleshooting and tried this same HDMI cable on another console using your current setup then it would lead me to believe that their is an issue with your HDMI port on your console is indeed faulty and you'll need to contact XBOX Support for your region to setup a repair or you can set one up yourself at http://myservice.xbox.com. If the XBOX is under warranty the repair is free, if the XBOX 360 is not under warranty then you will need to pay $99 for the one time repair.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.