Frequent disconnects from Xbox Live/Party/Etc.

It appears that this is a recurring problem on the forums, so I'll try to put as much relevant information so I'm not completely redundant (AND maybe, someone here might come up with something that I haven't already tried).

Problem: I can go 30, maybe an entire hour of multiplayer online gameplay (MW3, BF3, etc.) before I get kicked out of my xbox live party and the game session (if MW3) or game server (if BF3). I'm probably the only person in my group of friends that have this problem when we're in an xbox live party and playing (of varying numbers, sometimes 2, 3, 6, size of party doesn't seem to matter here). This seems to happen frequently and consistently, but there's nothing I do out of the ordinary that would warrant frequent disconnects (just happens within regular online gameplay). Typically the I can rejoin the party easily, and go through the frustration of having to rejoin the game session/server/whatever. 

This problem started up early last month. I had previously thought it to be a wireless issue - until I got an ethernet cable and the problems persisted. Suggestions? Relevant information below. 


What Country/State/Province do you live in? Indiana

Modem brand & model number: Don't know yet, will check, give me another suggestion in the meantime. 

Router brand & model number: Rosewill RNX-EasyN4 

If Wireless, are you using a white or black external adapter, or an internal (Xbox 360S) adapter? Not Wireless

Things you have tried: 
1) Restart XBox 2) Restart Router 3) Restart Modem AND Router 4) Unplug everything from Router except XBox 5) Set XBox IP to DMZ on router 6) Forwarded Ports 7) Clear System Cache 

 In short, aside from replacing the Xbox, the Router and the Modem - I've probably done it. 

Is UPnP Enabled? Yes

Do you have a NAT error? If so, what is your NAT? Nope. 

Any Error Codes you encounter: None
Who is your ISP(Internet Service Provider)? Comcast
After you run "Test Xbox LIVE connection" press “Y” for "More Info”. In the pop-up that appears, what are the following values, if shown? (If a value below does not appear for you, just leave it blank.)

W: 0000 - 000B
X: 0001 - 8005
Y: 20A8 - 4800
Z: 0000 - 0000
ID: FFFF - FFFF
L: 0015 - 10F0
Q: 8015 - 100D
T: Wired 
A: 192.168.0.120/255.255.255.0
G: 192.168.0.1
D: 192.168.0.1/0.0.0.0

 

Question Info


Last updated July 4, 2018 Views 3 Applies to:

Okay, got this info as well: 

Modem brand & model number: D-Link DCM-202

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

i am having same problem, but in partys and private either kicks me out or i they cut off while there talking need help i did i could now what?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey there Doctor! I understand you are having issues with consistently being connected to LIVE. I'd like to clarify, does this only happen in fast-paced games like MW3 or BF3, or does this also happen in apps or when navigating the dashboard? Also, since there seems to be some involvement with parties, I would like you to check your NAT to see what it is set to. Please check out our NAT Guide (forums.xbox.com/.../34069.aspx) to see what it is set for and make sure it is open. Also, just to be thorough, can you please go to http://speedtest.net on a computer on the same network as your console, take the test there, and post the result image back here. Thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

1) Happens in any multiplayer setting (hell, got disconnected playing the multiplayer demo of Mass Effect 3). I might get some lag watching the ESPN app, but then again, never was in an xbox live party unless I was actually playing. Side note: While being idle on BF3 (while trying to diagnose this problem), my connection with EA online seems to intermittently disconnect as well. 

2) NAT is open.

3)

My guess is, either 1) My router is in need of replacing (probable) 2) I need to have a conversation with Comcast ISP about the quality of my internet service. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey Flip, thanks for the info. The connection speeds look good, though I'm a bit concerned about that ping. To get a better look at that, can you please run another test at pingtest.net, and post those results here? To test the router, let's try bypassing it with an Ethernet cable and connect directly to the modem. :-)  

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.