Forza 5 intro video looping game won't start

Hello all I picked up an XBO and forza at the weekend. All went well on day one I set it all up and had a couple of hours on forza, all good. On Sunday however I switched it on fired up forza and was greeted with an infinite loop on the intro video. The menu loads I press A the video plays but then takes me straight back to the menu which just repeats over and over if I press A again, so the game is no longer playable. I contacted xbox support who have walked me through a number of steps (power drain, reset alternate mac, delete save game and uninstall the game) none of which have worked. They are now suggesting that it may be a faulty disk, however I am doubting this as googling the error has uncovered other examples where people have had this with the digital copy of the game. Anybody else experienced this? Thanks Neil
 

Question Info


Last updated July 4, 2018 Views 1 Applies to:

The same has happened to me. This is supposed to be the flagship launch game for xbox one and six months down the line it still has game breaking bugs in it. I can understand these types of issues at launch but six months after!?Maybe they should focus on fixing the game before trying to squeeze more money out of us with ridiculously overpriced dlc which should have been in the game to start with.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Sorry to hear what happened to you guys. It seems that the savegame is corrupt and  the the only fix that I know that will work is to delete the savegames from everywhere (cloud and console).

1. Go to games and apps

2. Find Forza 5

3. Click on "Menu button" select manage game and delete save games everywhere

4. Hold down the power button for 10 seconds

5. Turn the console back on

6. Enjoy the game

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey there, HairyBuzz! I appreciate your enthusiasm to help others out, but this thread is kind of old. The original poster may have already discovered a fix. However, there are plenty of other threads out there that are more recent! Head on over to those and drop some knowledge on your fellow gamers! :D

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.