Finished game not apper on Game Library.

I have a problem with one of my game,i finished ALL the achivments on that game,and it use to apper on the dasboard on the gamelibrary like this one :http://imageshack.us/photo/my-images/24/nvtelenaah.png/,but mine not,first game i fully finished it was a arcade game and after a while i deleted because i didnt play with it anymore,i deleted and the game and the game's cover gone as well on the game library and after that dont matter how many game i finish its not apper on game library.Why?! and what can i do with?! i dowloaded the arcade game again and thats game cover came back,but the rest not and i couldnnt just go back delete the last achivment and doit again see if is works..

Please guys help me!!and sorry about my crapy english :S i just needed to explain it with details.

 

Question Info


Last updated July 4, 2018 Views 7 Applies to:

When you go into your game library and view the achievements for the game do they show as 100% completed?.

1, Try clearing your cache, it may help/it may not, but its worth a try...
(Go to memory> highlight the HDD> press Y> Yes)

This will delete all your game updates so you will need to re download them the first time you play after clearing

2, Also you could try recovering your gamertag via the dashboard.
(On your dashboard make sure no profiles are signed in> press the xbox guide button and select recover account).

You need the accounts wlid (E-mail) and password to recover

If these steps do not help then fingers crossed some other users will have some more helpful suggestions for you...

PS: Nothing wrong with your English..

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Perhaps you got the last achievement while offline and deleted the game before going online so it could register?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I think sync is stopped until you get the latest firmware.  Did you update the console OS?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.