Faulty Controller?

Hi All,

I Have read a few comments on here about problems when connecting a second controller.

I Got a spare controller with my X1, the first time my girlfriend used it, it worked fine. However, yesterday she wanted to play some Ghosts with me so we set it up and when the game started her character just kept firing until she had no ammo (she even let go of the pad and it carried on). It wouldn't even let her aim down sight or even move at first.

I Tried a few things, loaded up another game, it let her move and it wasn't firing automatically but the triggers werent responding at all.

I Thought i would try a different game so i loaded up Forza, started a race to find that (without pressing anything) the car just sat on the start grid revving like mad but not moving.

All other buttons seem to work in game but the A button is very unresponsive on the dashbord. It takes several presses on a tile to get it to do anything....... i wondered if my console was playing up but it works perfectly when using my controller.

I'm pretty sure its faulty but thought i would ask just in-case these are the second controller issues people were referring to before i contact ShopTo to get the pad changed.

Any help would be appreciated.

 

Discussion Info


Last updated July 4, 2018 Views 5 Applies to:

I'd get it exchanged mate. Does sound like a problem with the pad.

Like everything with wires and circuits, sometimes things go wrong.

Thought as much. Thanks mate