Error Code 80151901.

For the past few days I have been completely unable to connect to live. Whenever I attempt too I get the error code 80151901 and asked to test  my network connection - which always failed at (xbox---X---network). However after I had input all the network info manually (IP address, gateway, dns) and now when testing my connection I get an error at (network---X---internet) instead.

Now I have read a lot of these threads popping up lately with the same error code and I have followed every single piece of advice given. I have cleared my cache x3, I have restored my consoles network settings to factory default, I have deleted and tried to redownload my profile (of course that didn't work so I am profiless), I reinstalled my dongles software (I use a dongle and ICS to get on live, which shouldn't be a problem it's worked for years.) and I used the LB RB X LB RB X trick to delete the latest update and reinstalled it via USB. None of this helped at all. 

I am beginning to think it may be a server issue as there have been a number of threads dealing with this topic popping up lately. I know for a fact my ethernet port and cable still work as I am able to system link with another xbox. And my dongle is working fine, in fact it's what I'm using to post this.

I am honestly at my wits end here trying to think of a solution, could anyone help me at all? If it's relevant in any way a few days before it stopped connecting I was receiving a -lot- of requests for security info (email/password etcetc).

 

Question Info


Last updated July 4, 2018 Views 4 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Also sorry for the lack of spaces between paragraphs - the formattings kinda weird.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Dragon,

Thank you for creating your own thread, and sorry to hear about the connection troubles. Let's see if we can get this working.

To get a better idea of your network setup, please reply to the bold details below.  

What Country/State/Province do you live in? 
Modem brand & model number: 
Router brand & model number: 
If Wireless, are you using a white or black external adapter, or an internal (Xbox 360S) adapter?
Things you have tried: 
Is UPnP Enabled? Yes/no/Unknown
Do you have a NAT error? If so, what is your NAT type?
Any Error Codes you encounter: 
Who is your ISP(Internet Service Provider)? 
After you run "Test Xbox LIVE connection" press “Y” for "More Info”. In the pop-up that appears, what are the following values, if shown? (If a value below does not appear for you, just leave it blank.)
W:
X:
Y:
Z:
ID:
L:
Q:
T:
D:
S:
C:
 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi, thanks for the reply. Here's the info.

What Country/State/Province do you live in?

Britain/England/Somerset

Modem brand & model number:

Huawei E1550

Router brand & model number:

No need for one as I connect via ICS on my PC

If Wireless, are you using a white or black external adapter, or an internal (Xbox 360S) adapter?

N/A

Things you have tried:

Clearing cache x3/restoring factory defaults/restoring profile/reinstalling modem/rolling back last update/manually inputting network info.

Is UPnP Enabled? Yes/no/Unknown

Unknown

Do you have a NAT error? If so, what is your NAT type?

N/A as I'm not using a router

Any Error Codes you encounter:

80151901 Whenever I try to sign in.

Who is your ISP(Internet Service Provider)?

Three

After you run "Test Xbox LIVE connection" press “Y” for "More Info”. In the pop-up that appears, what are the following values, if shown? (If a value below does not appear for you, just leave it blank.)

W:0000-000B

X:0000-000D

Y:0000-0000

Z:8015-1904

ID:0002-0001

L:0015-10F1

Q:8007-0435

T:Wired

(The last three letters of this list are different for me for some reason)

D:(A) 192.168.0.2/255.255.255.0

S:(G) 192.168.0.1

C:(D) 172.31.139.17/0.0.0.0

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Dragon,

Thank you for the info.

Looking into those X,Y,Z codes, this issue seems to be boiling down to a DNS issue. How exactly are you bridging your connection? Are you Using Windows Internet Connection Sharing or Creating a network bridge connection

Also, you said this started a few days ago. Did anything happen or change when this started happening? 

Let us know, and we can work from there.  

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Thanks for the response.

I am using internet connection sharing. As far as I know nothing about my connection has changed since I originally set it up over a year ago. I ran ipconfig /all and entered the DNS it told me into the xboxs network settings to try and fix the issue. After that my xbox would recognize the network but still could not find any internet connection.

So far I'm pretty certain I can rule out:

- Dodgy ethernet cable (tried a couple and my xbox finds the network okay)

- The network adapter on my PC and xbox (My PC finds the xbox fine and vice versa)

- My dongle (I can connect to the internet fine on my PC)

- My xboxs network settings (I Inputted all the info ipconfig told me)

- Any corrupt data on my HDD (I scoured the entire drive looking for corrupt data but none to be found)

It's honestly a bit of a mystery :/ I appreciate you taking the time to help me!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey there Dragon,

Just wanted to double check,

  1. Are you using any third party headsets?
  2. The DNS Error path in our Connection Error Troubleshooter has a lot of different suggestions for a wireless connection.
    1. Have you double checked the different solutions there?





It's not an official support solution, but you may also want to try using the Google Public DNS addresses as an alternative to your provider's.



Please let us know and we'll work from there. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi, thanks for the response!

I'm not currently using any headsets official or third party and I double checked every suggestion in the troubleshooter but I had no luck still :(

I just tried changing my dongles DNS settings to the Google address and my PC connects fine with those settings but my xbox still refuses to find the internet whether I put the DNS in manually or use automatic settings. It really doesn't make much sense :/

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Oh I should probably clarify my connection is wired - e.g my dongle plugs into my PC via USB and I then run an ethernet cable to my xbox and connect via Internet Connection Sharing. It's worked fine for over a year and I hadn't changed any of the settings at all.

Sorry for the double post!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

OK so let me make sure I understand the internet setup here:

Xbox -> Ethernet to PC -> PC has a USB wifi dongle -> wireless to router

Am I getting that right?  Here's a couple things that come to mind:

1: maybe something is going funky in the wifi dongle.  Let's try plugging it into a different USB port.  

  • Also, what model is it?


2. Can you just straight up simplify this network setup at all?  Any chance you can get a wire straight from the console to the router? 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for the response.

My setup is Xbox -> PC -> PC has a USB 3G dongle, no router involved. I tried different USB ports but to no avail I'm afraid :( The dongle itself is a Huawei E1550.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.