Elite controller not charging.

I took the plug and play battery from my old controller to use in my new elite and switched out USB cables. Everything worked fine until just now. I received the notification of a low battery so I plugged it in. The low battery icon faded out from the dashboard and within a few minutes the low battery notification popped up again, while it was still plugged in. I unplugged the controller, and then plugged it back in. Same thing happened. I then put the old USB cable back in and tried again. Same thing happened, but the charge indicator light on the cable did not come on (I'm not sure if it's even supposed to, considering there isn't one on the new USB cable). Any ideas? Anyone else having this happen? The micro USB port on the controller is super snug, not sure if that's normal. 

Edit: When unplugging the cable from the controller, the Xbox button flashes, even though it is not providing power. 

 

Question Info


Last updated July 4, 2018 Views 62 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Edit 2 (I can't actually edit my post): I removed the battery pack and placed it in my old controller, and it shows as fully charged. When replaced back into the elite, it shows as fully charged.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey Pushmonk!

To clarify, after you switched the battery around it started showing correctly for you? Are you still seeing any issues with this or are you all good to go now?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same problem here.

My old Play and Charge charges fine in my old controller but won't charge in my Elite.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

My new elite controller does not charge also. I'll charge the battery in another controller until MS fixes it I guess. I unpluged it, plugged in a regular controller, and went back and now it's charging. The firmware version is 2.3.2369.2

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I too am having this issue. P&C cable shows orange for charging but battery level when powered on shows red no power.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm having a similar issue. The standard play n charge kit cable stays orange forever. The controller will charge somewhat with the braided cord that it comes with. When it shows fully charged it will show low battery after a few hours. Then I go to plug it in and then immediately unplug it and then it shows fully charged. It's is being weird.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey everyone!

hypo luxa mentioned they were using the Micro USB cable that was included with the Elite Controller which provides some charge. Can everyone else please clarify that they're using this cable to charge their controller? Thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Mister Maka,

Thanks for the reply.  I wish the elite braided cable came with some type of visual indicator like the standard play and charge cables in the form of a orange / white light that tells the user that the battery is charged.  It is very bizarre that the other 4 standard controllers that I own never have given me the "battery low" notification on screen whilst the elite controller gives it to me after a few hours or even after 20-ish so minutes of gameplay.  When I see this notification, I'll plug in the elite controller and then unplug it immediately or I'll even re-sync it and presto, the xbox elite controller reads full charge....and not low battery.  Is there a firmware issue going on right now because the elite controller shipped with its most current firmware version?   Seems really buggy to me....and to hear other folks having a similar issue above kindof makes me think it's not isolated.  Any thoughts?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

.....and to add one other thing.....the first night I tried charging the battery pack with the play and charge kit black cable, it never turned white.  It perpetually indicated orange.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I've been having this same problem, both old and new cable will never charge on the elite. No amount of switching will make it read the battery correctly, always red, NEVER charges. It will also not read normal AA batteries correctly. Popped in 2 brand new Eneloop batteries and they showed red.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.