Dragon Age Origins; Brecilian Ruins Elven ritual problems

I am curious if I am the only one that is or have had problems with this when trying to get the Juggernaut armor set. I know the combination for the earthen jug and alter to unlock the door but whenever I kneel to pray the water evaporates from the jug every single time. No matter where I look the combo is the same; fill jug, place filled jug on alter, pray, take a single sip, pour back in fountain. Is this even the right combo or is something wrong with my game... I have tried 10 different times on 10 different characters but none of them have worked and its getting really frustrating... HELP ANYONE?

 

Discussion Info


Last updated July 4, 2018 Views 3 Applies to:

You are slightly wrong but you need to be exact for this.

1) FOUNTAIN: Pick up a jug.

2) FOUNATIN: Fill the jug with water.

3) FOUNTAIN: Leave the fountain alone.

4) ALTAR: Place the jug on the altar.

5) ALTAR: Kneel down before the altar and pray.

6) ALTAR: Examine the jug.

7) ALTAR: Drink water from the jug.

8) ALTAR: Pick up the jug.

9) ALTAR: Leave the altar alone.

10) FOUNTAIN: Pour out the rest of the water into the fountain.

From http://guides.gamepressure.com/dragonageorigins/guide.asp?ID=8530. because I was too idle to type it from memory.