Dolby Digital 5.1 sound - buzzing/hacking

Hi!

Earlier I had no problems running my XBOX  360 Elite via HDMI. Now I have moved and must have lost some settings because when I first connected the XBOX to my TV I had no sound via HDMI.

I called support who adviced I could turn off Display Discovery. This got the sound back in the XBOX-menus, games seems ok etc. However, when I want to play a DVD, the sound start hacking/buzzing very loudly all the time. Same thing if I manually change audio settings from Digital Stereo to Dolby Digital 5.1, then sound immidiately start hacking in the XBOX-menu as well.

Any advice would be much appreciated.

/Frdrik

 

Question Info


Last updated July 4, 2018 Views 2 Applies to:

Hey there, freddan15. Thanks for bringing your question to the forums. Has anything else changed about your setup since you moved? Did you purchase a new TV or change your HDMI cable at all? If you can let me know anything that may have changed that would be very helpful for the troubleshooting process. Thanks in advance! Standing by for your response.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I Suggest checking your HDMI cord and all RC/Optical Cords for Damage to start off since you just moved, any pinched ends, Punctures, and Crimps to the cord can cause Noise/Static.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.