Disconnecting from Games but NOT LIVE or Parties

Hi, I have been playing Battlefield 3 with friends online for a few months now, however for the past two days, I have been able to play games for roughly 3-5 minutes and then suddenly get ejected from the game saying "`You have lost connection to the server".

Once this happens, I can immediately rejoin the game I was playing, then have the same happen a few minutes later.

It only happens to the game however. I stay connected on Xbox LIVE and stay in my Party, and can talk to the people in my party as I'm being disconnected.

I'm stumped. Please help.

BT HomeHub 2.0

White Wireless Xbox Adapter

 

Question Info


Last updated July 4, 2018 Views 5 Applies to:

Hey cammo! Can I have you try to reset your network hardware? You can reset your modem and router by unplugging power to both for around 15 seconds. When restoring power, plug the modem in first, and then wait for all of the lights on the modem to come up. When those are all active, plug in the router. Once those lights are flashing normally, go ahead and run a LIVE connection test on the console. Then can you provide us the information requested in bold in our Start Here sticky post. This will help us pinpoint your connection issue! :)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.