Disconnected from XBOX Live mid-game and cannot re-connect

I was in the middle of a multiplayer game on Black ops and I was disconnected from XBOX live. I tried signing in, but I get the following message

Can't connect to Xbox LIVE. Select Test Connection to troubleshoot, or try recovering your profile.

I tested the connection (Wired Connection) and can't connect from internet to XBOX LIVE. I get the following message.

Test Failed - There's a problem with your connection. Select More Info for a description of the problem and how you can fix it.

I then went to the XBOX LIVE Connect Solution troubleshoot page (http://support.xbox.com/en-us/pages/xbox-live/troubleshoot/connection-issues/cant-connect-to-xbox-live-wizard.aspx) and followed all the steps. (i.e. I reset to connection setting to factory default, I shut the xbox off, unplugged the router, unplug the modem, waited a few minutes and then tried again, I even connected my xbox direct to the modem and tried wireless. Same thing)

The internet works great, I can browse and type this post.

 

Some more info

Alberta, Canada

Modem Motorola SB5101 SURFboard Cable Modem

Router D-Link DIR-655 Wireless Router

I don't know what a UPnP is

Open NAT

ISP is Shaw

 

As I said, I have been on XBOX live for year and played this weekend, this is the first time this happens and I did not move/touch/do anything to my setup.

 

Your help is greatly appreciated.

 

Question Info


Last updated July 4, 2018 Views 8 Applies to:

As soon as I posted this, I tried to log on and it works :-s. no need to answer this.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

i just disconnected 10 mins ago and also cant get back on and same thing here, nets fine, a lil slow but fine... but i also have a motorolla modem but... i dont think thats he cause... wtf is going on?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I had the same problem and i also have a motorolla modem. but all i did was just leave my router and modem disconnected for a couple minutes and plugged them all back it and it worked again.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.