Disc will not eject.

Don't know if I'm doing something wrong. I returned the console I purchased last week because the disc wouldn't eject. I just got the new one set up and it won't eject the disc either. 

 

Question Info


Last updated July 4, 2018 Views 22 Applies to:

Hi IllTugboat61726, 

Sorry you're having issues getting your discs to eject. Do you hear the chime when you touch the button, or does it even try to eject? If you hear a chime, then you know your finger is registering and it's not something with the front panel.

With the eject I would first try doing a hard reset. To do this with the console on, hold the power button down for about 8 seconds until the power just turns off. After it's off turn it back on and test the eject. If that doesn't work, I would suggest unplugging your console for about 5 minutes. After 5 minutes, plug it in and try again (normally I don't say that, but in some cases like this it does work as the power supply holds power for quite a while). If it's still not working, ensure that the front panel is clean and free of any smudges or dirt and try again. Finally as a last ditch effort you can try doing a factory restore by following this link

If it's still not working, then I would suggest trying to exchange the console again. It would be extremely unlikely that you have two consoles both with bad disc drives, and if that is the case, I couldn't see a third having the same problem. If you need to manually eject a disc follow this link

MCP. MCDST. LVL 80

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.