Difficult NAT Problems

Alrighty then, so here's a list of things that are currently facts:

-I have a Linksys WRT54G router

-My XBox has a static IP address

-I currently have the proper ports forwarded for the XBox's IP address

-I also have my XBox's IP set as the DMZ host

-I have UPnP enabled on the router

-I have tried both hardwiring the XBox into the router and using a wireless adapater

-And yet, my NAT stubbornly remains "Moderate"

 

This would not be a problem if not for the fact that it prevents me from connecting to games with, literally, almost every single one of the friends who I actually care to play with. I have tried all the standard NAT fixes mentioned here and elsewhere (you know, the ones with step-by-step picture guides that are narrated by Bill Nye), and, while I can get a problem-free NAT on any other machine on my network (mostly Macs or PCs), the XBox refuses to get with the program.

Does anybody have a solution to this problem?

 

Question Info


Last updated July 4, 2018 Views 0 Applies to:

Hi,

 

You are over configuring your router, your are using UPnP and forwarding and a DMZ so the router is getting very confused as they all provide the same service for the xbox. Use only one of the methods, use UPnP only with no forwarding or DMZ and with the Xbox ip address on auto. If that doesn't work turn off UPnP set a static ip address and use forwarding, if that fails turn off UPnP and forwards and use the DMZ

 

Restart your router after making any changes

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Although you took, what i believe from reading your post, was the proper approach, i think your problem may lie in having both port forwarding and UPnP enabled. For routers, having multiple networking options of Port Triggering, Port Forwarding, and UPnP are all nice and dandy. But, you only need to pick one or the other, otherwise this could create problems.

Try picking just UPnP first and only that, (while leaving all other options alone, off, or defaulted), as it usually just fixes it on the spot and it simplest to do for basic internet users. On a side note, you may want to get back a dynamic IP setup on your Xbox 360 before trying UPnP. I wouldnt take my word for it, but just as a word of caution.

If this doesnt work, turn off UPnP, and then only reenable only port forwarding as you have previously setup before, then try again. Side note again: Switch back to Static IP for this part, but i believe you may know what you're already doing at this point.

If any of these options dont work or show improvement in your NAT, you could take it up with your ISP. But i hardly doubt it will get you anywhere as they may or may not throw you into steps i laid out or the ones you have already tried. Otherwise, NAT's just seem to change sporadically depending on the area the network traffic in your area.

Hope this or anyone else's suggestions help you out!

-CrazyIvan316

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Success.

After disabling UPnP and DMZ, setting the IP to static, and hitting the proper ports between the eyes at a thousand yards, I finally managed to get that little thing in the corner to say "Open."

Now, solutions like this have worked in the past, only to fail me later. However, the fragile 'Open NAT' crown which now sits atop my XBox managed to survive a restart or two, so things are looking optimistic.

For now, solved. Much obliged, folks.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

No problem, as its set-up now it should not change

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Im running off a unprotected network around my house, and it's says that my NAT setting is moderate, and also says that I wont be able to connect to certain people. How do I fix this?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Please start your own thread with your own details posted, thanks

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

1) Go to the Security tab, then the Firewall section. Uncheck "Filter Internet NAT Redirection" and click on Save Settings.

2) Go to the Administration tab, then the Management section. Set UPnP to Enable. Click on Save Settings. This will cause your router to cycle, so you may momentarily lose your internet connection.

Retest the network on your Xbox 360 and NAT should be listed as Open.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.