Dead Rising 3 Update Problem

Recently when I try to play Deadrising 3 it says I need an update,which I expected as I knew there was an update necessary, however there is a problem when I try to update it won't let me, as it tells me the update has failed, and when I try again it instantly gives the same message.

This is extremely annoying, because just before I experienced this issue, I bought the season pass and downloaded all the content as I wanted to play it, and now can't.

Any help would be appreciated thanks

 

Discussion Info


Last updated July 4, 2018 Views 1 Applies to:

Not guaranteed to work but have you tried ..

Hard Rebooting the console?

Deleting then reinstalling everything again?

Is it the huge 13GB update you are having issues with? if so I've heard others that had problems with it so it's not just you.

I guess you could have a look in the links below, there's a few posts ( if you scroll through a few pages ) where people have reported problems.

forums.xbox.com/.../4090.aspx

www.xboxachievements.com/.../forumdisplay.php

Good luck.

I had this problem as well, I uninstalled the game, then reinstalled and it seemed to work, hopefully it will work

Yeah the above steps would be the first things to try out in order to fix a problem like this and I hope they have the intended result for you. Thanks for jumping on this guys!

Hopefully it works.

Thanks for the replies, trying the uninstalling tip.

I'll get back to you if it works

Cool. Hopefully it works out for you :)

If it is a disc based game, I had a bug where the drive wouldn't wake up from sleep (they might have fixed this in the latest build) and would try to update but kept failing. ejecting the disc and popping it back in fixed it.

Could be something worth remembering to try if it happens again.

IRB

Thanks IRB, but the uninstalling tip worked.

Thanks for all your help guys.

Glad its all sorted for you :)

Thanks again everyone for jumping in here!