Controller Update for Stereo Headset Adapter Fails

Using Turtle Beach x12's.

I have followed the instructions verbatim.  I have tried with 2 different controllers to no avail I get message There was a problem updating your controller.

I was able to update the controllers (analog sticks) but when I plug in the headset adapter, I get prompted to update the controller and I am aware this is a separate update.

  • I have unplugged the batteries
  • Ensured only one controller plugged in
  • Plugged in the headset adapter then attach controller via micro usb
  • Power cycled the xbox by holding down for 5 secs and leaving off for 10
  • Tried with mic unmated and muted
  • Tried with volume and no volume coming into headset

I have searched up and down can can not find any solutions as of yet, and I don't see anyone else reporting this issue.

I found one post that stated there is another update coming out tomorrow (7th) for the headsets, but I am reading other folks with x12's are already updated and running.

Any help or suggestions would be greatly appreciated.

 

Question Info


Last updated July 4, 2018 Views 83 Applies to:
Answer

I called tech support from Microsoft, ran through the same t/s steps I had taken.  We have identified the problem to be the actual headset adapter.  Going to have to get it replaced.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.